Bug 517483 - Anaconda fails to install to entire drive if hostname has maximum size
Summary: Anaconda fails to install to entire drive if hostname has maximum size
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 10:09 UTC by Miroslav Vadkerti
Modified: 2009-08-20 01:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 01:15:54 UTC
Type: ---


Attachments (Terms of Use)
Bug if maximal hostname (43.81 KB, image/png)
2009-08-14 11:27 UTC, Miroslav Vadkerti
no flags Details
Exception - File Bug (79.06 KB, image/png)
2009-08-14 11:27 UTC, Miroslav Vadkerti
no flags Details
anaconda exception dump after save-to-bugzilla (230.66 KB, text/plain)
2009-08-16 08:08 UTC, Miroslav Vadkerti
no flags Details

Description Miroslav Vadkerti 2009-08-14 10:09:20 UTC
Description of problem:
Anaconda fails to install if hostname has maximum size. If File Bug button is clicked also an exception is raised. See attached screenshots.

Version-Release number of selected component (if applicable):
anaconda-12.7

How reproducible:
always

Steps to Reproduce:
1. Set hostname to maximum size
2. Use entire drive (I don't think it depends on this)

  
Actual results:
Error appears

Expected results:
No error

Additional info:

Comment 1 Miroslav Vadkerti 2009-08-14 11:27:01 UTC
Created attachment 357434 [details]
Bug if maximal hostname

Comment 2 Miroslav Vadkerti 2009-08-14 11:27:33 UTC
Created attachment 357435 [details]
Exception - File Bug

Comment 3 James Laska 2009-08-14 12:40:55 UTC
Miroslav, nice bug!  Can you recreate this failure on the latest rawhide that includes anaconda-12.15 or newer?

Once you hit the failure, if the save-to-bugzilla dialogs do not work, please manually attach the /tmp/anacdump.txt file to this bug report.  If the traceback dialogs continue to fail, let's log that as a new bug.

Thanks!
James

Comment 4 Miroslav Vadkerti 2009-08-16 08:06:49 UTC
Hi James, I just reproduced this bug on anaconda-12.15.

Also the save-to-bugzilla dialog still fails, attaching anacdump.txt here as you requested.

Comment 5 Miroslav Vadkerti 2009-08-16 08:08:33 UTC
Created attachment 357559 [details]
anaconda exception dump after save-to-bugzilla

Comment 6 Miroslav Vadkerti 2009-08-16 08:37:05 UTC
New bug for save-to-bugzilla issue added:
Bug 517699 -  Exception after File Bug - save-to-bugzilla doesn't work

Comment 7 Chris Lumens 2009-08-17 14:22:19 UTC
The exception you're seeing when you click "File Bug" is the actual exception that occurred in the storage code, not some new thing due to an error in the bug filing code.  In light of that information, is 517699 still a problem?

Comment 8 Chris Lumens 2009-08-17 17:03:56 UTC
David - you did the hostname -> LV name code, I believe.  To test, just punch in a really really long hostname on that screen in anaconda and wait for the tracebacks.  Looks like we need to modify both the code that comes up with LV/VG names as well as the code that puts the two together into device nodes.

Comment 9 David Cantrell 2009-08-20 01:15:54 UTC
A fix for this has been committed to the git repository and will appear in anaconda-12.17-1.


Note You need to log in before you can comment on or make changes to this bug.