Bug 517496 - Alsa driver snd_intel8x0 fails, stop playing sound after a while
Alsa driver snd_intel8x0 fails, stop playing sound after a while
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-14 07:44 EDT by Uno Engborg
Modified: 2009-08-17 15:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 15:36:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uno Engborg 2009-08-14 07:44:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.6.29.6-217.2.3.fc11.i686.PAE

How reproducible:
Very, it typically happens if you try to play a sound that is five minutes or longer. E.g  viewing a flash video.

Steps to Reproduce:
1. Run the video at:
http://www.netbeans.org/kb/docs/web/js-debugger-screencast.html (you will probably have to have Adobe flash installed, first)

  
Actual results:
Sound is fine the first few minutes, but after a while the sound disappears

Expected results:
Sound all the way

Additional info:

My /var/log/messages gets the following error messages when I try to play the video in the URL above:

Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: snd_pcm_dump():
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0




The full /var/log/message ouput to playing the video looks like this.


Aug 14 12:57:30 humlan pulseaudio[13226]: alsa-sink.c: Device hw:1 is modem, refusing further initialization.
Aug 14 12:57:30 humlan pulseaudio[13226]: alsa-source.c: Device hw:1 is modem, refusing further initialization.
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-sink.c: Increasing minimal latency to 1,00 ms
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-sink.c: Increasing minimal latency to 2,00 ms
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294964424 bytes (24347870 ms).
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: snd_pcm_dump():
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Its setup is:
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   stream       : PLAYBACK
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   format       : S16_LE
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   subformat    : STD
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   channels     : 2
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   rate         : 44100
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   exact rate   : 44100 (44100/1)
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   msbits       : 16
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   buffer_size  : 16384
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_size  : 16384
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_time  : 371519
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_step  : 1
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   avail_min    : 16384
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_event : 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   start_threshold  : -1
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   stop_threshold   : 1073741824
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   silence_threshold: 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   silence_size : 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   boundary     : 1073741824
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   appl_ptr     : 4293331
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   hw_ptr       : 4276229
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 349372 bytes (1980 ms).
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: snd_pcm_dump():
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c: Its setup is:
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   stream       : PLAYBACK
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   format       : S16_LE
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   subformat    : STD
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   channels     : 2
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   rate         : 44100
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   exact rate   : 44100 (44100/1)
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   msbits       : 16
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   buffer_size  : 16384
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_size  : 16384
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_time  : 371519
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_step  : 1
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   avail_min    : 16384
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   period_event : 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   start_threshold  : -1
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   stop_threshold   : 1073741824
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   silence_threshold: 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   silence_size : 0
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   boundary     : 1073741824
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   appl_ptr     : 4363891
Aug 14 12:59:07 humlan pulseaudio[13226]: alsa-util.c:   hw_ptr       : 4276548
Aug 14 12:59:12 humlan pulseaudio[13226]: ratelimit.c: 8677 events suppressed
Aug 14 12:59:17 humlan pulseaudio[13226]: ratelimit.c: 9802 events suppressed
Aug 14 12:59:22 humlan pulseaudio[13226]: ratelimit.c: 9812 events suppressed
Aug 14 12:59:27 humlan pulseaudio[13226]: cpulimit.c: Received request to terminate due to CPU overload.
Comment 1 Rosen Nedyalkov 2009-08-17 14:50:47 EDT
I can confirm this happening always on Thinkpad X41. FC11, i386. Smolt config is: http://smolt.fedoraproject.org/client/show_all/pub_8df756f2-4ca4-42bb-9211-7464d4ca36e4
Comment 2 Rosen Nedyalkov 2009-08-17 15:36:27 EDT

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.