Bug 517532 - telnet install fails - loader received SIGABRT! Backtrace:
Summary: telnet install fails - loader received SIGABRT! Backtrace:
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 13:37 UTC by James Laska
Modified: 2013-09-02 06:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 17:12:38 UTC
Type: ---


Attachments (Terms of Use)

Description James Laska 2009-08-14 13:37:19 UTC
Description of problem:

A telnet (yes telnet) install fails with a SIGABRT when connecting to the installing system.

Version-Release number of selected component (if applicable):

 * anaconda-12.14

How reproducible:


Steps to Reproduce:
1. Boot installer by any available means
2. Add boot argument "telnet"
3. When prompted, telnet into installing system to proceed
  
Actual results:

loader received SIGABRT!  Backtrace:
/sbin/loader[0x1000590c]
[0x100364]
[0xff8ea978]
/lib/libc.so.6(abort+0x25c)[0xf70286c]
/sbin/loader[0x1001ff1c]
/sbin/loader[0x10020248]
/sbin/loader[0x100205e0]
/sbin/loader[0x1000805c]
/lib/libc.so.6[0xf6e751c]
/lib/libc.so.6[0xf6e76c0]
install exited abnormally [1/1] 
you may safely reboot your system


Expected results:

 * No SIGABRT

Additional info:

Comment 1 James Laska 2009-08-14 13:52:51 UTC
This bug is interesting ... and *low* priority of course

telnet works fine if you run from a terminal:
 # telnet host1.example.com

However, out of habit, I ran this out of the gnome-run dialog ... which causes the SIGABRT.

Comment 2 James Laska 2009-08-14 14:55:40 UTC
backtrace on x86_64

loader received SIGABRT!  Backtrace:                                           
/sbin/loader[0x40762e]
/lib64/libc.so.6[0x7f513d6096f0]
/lib64/libc.so.6(gsignal+0x35)[0x7f513d609675]
/lib64/libc.so.6(abort+0x175)[0x7f513d60ae55]
/sbin/loader[0x41eb3f]
/sbin/loader[0x41ec70]
/sbin/loader[0x41efc1]
/sbin/loader[0x409c75]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7f513d5f4b8d]
/sbin/loader[0x4057d9]
install exited abnormally [1/1] 
you may safely reboot your system

Comment 3 Chris Lumens 2009-08-14 14:58:52 UTC
eu-addr2line sez...

0x41eb3f - /usr/src/debug/anaconda-12.14/loader/telnet.c:145
0x41ec70 - /usr/include/bits/fcntl2.h:54
0x41efc1 - /usr/src/debug/anaconda-12.14/loader/telnetd.c:251
0x409c75 - /usr/src/debug/anaconda-12.14/loader/loader.c:2019

Comment 4 Chris Lumens 2009-08-25 17:12:38 UTC
This would be a rather nasty fix - it's in seven year old code that hasn't been touched except for when files move around since then.  The workaround seems easy enough (run from a terminal instead of gnome-run) and would probably take way more time than it's worth in anaconda land to come up with a fix.  I'll WONTFIX it for now.


Note You need to log in before you can comment on or make changes to this bug.