Bug 517542 - [anaconda] wrong keyboard layout after install and /etc/sysconfig/keyboard missing
[anaconda] wrong keyboard layout after install and /etc/sysconfig/keyboard mi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-08-14 10:30 EDT by Joachim Frieben
Modified: 2009-10-02 03:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 03:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-08-14 10:30:39 EDT
Description of problem:
After a fresh install from the "rawhide" tree, the keyboard layout in a VT is not the one selected during install. Likewise GDM displays a default English keyboard layout whereas a German one had been chosen.
Moreover, file /etc/sysconfig/keyboard is missing.

Version-Release number of selected component (if applicable):
anaconda-12.13-1.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora from the development tree.
  
Actual results:
Default keyboard layout is English.

Expected results:
Default keyboard layout is German as chosen by the user.

Additional info:
- Issue has been observed on two different systems (i686, x86_64) on the same day.
- Creating /etc/sysconfig/keyboard makes GDM display the correct default layout.
- It is conceivable that /etc/sysconfig/keyboard is doomed to disappear. In this case,
  I would assume a HAL issue.
Comment 1 Joachim Frieben 2009-08-14 10:58:01 EDT
Kernel boot options according to /etc/grub.conf include

  KEYBOARDTYPE=pc KEYTABLE=de-latin1-nodeadkeys .

Previously installed F11 had set up a keyboard file with options

  KEYBOARDTYPE="pc"
  KEYTABLE="de-latin1-nodeadkeys"
  LAYOUT="de"
  MODEL="pc105"
  OPTIONS=""
  VARIANT="nodeadkeys" .
Comment 2 Chris Lumens 2009-08-17 12:56:14 EDT
diff -ru system-config-keyboard-1.3.0.orig/lib/keyboard.py system-config-keyboard-1.3.0/lib/keyboard.py
--- system-config-keyboard-1.3.0.orig/lib/keyboard.py	2009-08-17 10:55:25.000000000 -0400
+++ system-config-keyboard-1.3.0/lib/keyboard.py	2009-08-17 12:59:33.000000000 -0400
@@ -120,7 +120,7 @@
 
     def read(self, instPath = "/"):
         try:
-            file = open("/etc/sysconfig/keyboard", "r")
+            file = open(instPath + "/etc/sysconfig/keyboard", "r")
         except:
             return
         self.config = []
@@ -133,7 +133,7 @@
         self.beenset = 1
 
     def write(self, instPath = "/"):
-	file = open("/etc/sysconfig/keyboard", "w")
+	file = open(instPath + "/etc/sysconfig/keyboard", "w")
 	for line in self.config:
                 file.write (line[0]);
         try:
Comment 3 Joachim Frieben 2009-08-17 14:04:56 EDT
Forgot to add this one [even though a fix seems to be on its way already]:
# rpm -ihv kernel-PAE-2.6.31-0.151.rc5.git3.fc12.i686.rpm 
Preparing...              ########################################### [100%]
   1:kernel-PAE             ########################################### [100%]
/sbin/new-kernel-pkg: Line 446: /etc/sysconfig/keyboard: File or Directory not found
Comment 4 Lubomir Rintel 2009-08-18 01:55:54 EDT
Thanks for the report & patch.
Built, requested for tagging into f12-alpha. (rel-eng ticket #2128)

Note You need to log in before you can comment on or make changes to this bug.