Bug 517558 (Xavier) - unable to compile ufraw with lensfun support
Summary: unable to compile ufraw with lensfun support
Keywords:
Status: CLOSED RAWHIDE
Alias: Xavier
Product: Fedora
Classification: Fedora
Component: ufraw
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL: http://ufraw.sourceforge.net/lensfun....
Whiteboard:
: 523542 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 17:05 UTC by Xavier
Modified: 2010-05-04 13:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 11:58:11 UTC


Attachments (Terms of Use)

Description Xavier 2009-08-14 17:05:42 UTC
Description of problem:

the spec contains a mistake in the configure options. The right option to compile ufraw with lensfun is "--with-lensfun", not "--enable-lensfun"

Version-Release number of selected component (if applicable):
ufraw-0.15-3.fc11.src.rpm
  
Actual results:
it is impossible to compile ufraw with lensfun support

Expected results:
use lensfun library to correct lens defects.

Comment 1 Nils Philippsen 2009-08-17 11:58:11 UTC
Hmm, this really means UFRaw hasn't been tested with lensfun so far. I'll change it in devel CVS and rebuild the package on Rawhide, but won't enable lensfun in F-11 or earlier because it's not tested there and it really shouldn't be without enough testing, see: http://ufraw.sourceforge.net/lensfun.html

Comment 2 Nils Philippsen 2010-05-04 13:32:45 UTC
*** Bug 523542 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.