Bug 517582 - pt_chown requires mmap_zero and caught by selinux
pt_chown requires mmap_zero and caught by selinux
Status: CLOSED DUPLICATE of bug 525537
Product: Fedora
Classification: Fedora
Component: libcap (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
: 524369 525309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-14 15:22 EDT by Jerry
Modified: 2009-10-13 11:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 11:59:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested output from ausearch -m avc -i (2.29 KB, text/plain)
2009-08-14 16:38 EDT, Jerry
no flags Details

  None (edit)
Description Jerry 2009-08-14 15:22:40 EDT
While running gcc testsuite after update to glibc, SELINUX gives error preventing pt_chown because of attempt to use mmap_zero

node=quattro.localdomain type=AVC msg=audit(1250222756.953:83): avc: denied {
mmap_zero } for pid=4939 comm="pt_chown"
scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
tclass=memprotect

The pid-4939 belongs to 'expect' running as part of gcc testsuite.

See initial report in #515521 Comment 27 which shows the full alert message. Workaround is the fix to devpts discussed in that bug report.
Comment 1 Daniel Walsh 2009-08-14 15:59:01 EDT
I don't think this should need this.

Jery can you get the entire message out of the audit log

ausearch -m avc -i
Comment 2 Eric Paris 2009-08-14 16:08:15 EDT
it absolutely does not need this permission, with the full syscall we might find it to be the problem in which a full vm space can try to allocate between 4096 and mmap_min_addr dynamically (prelink was hitting that before we turned mmap_min_addr down to 4096).   This is still a problem in the upstream vm.  I can verify with the full audit message.
Comment 3 Jerry 2009-08-14 16:38:32 EDT
Created attachment 357503 [details]
Requested output from ausearch -m avc -i

I am reproducing this on another machine.  Again while running gcc testsuite.

Atacched audit as requested
Comment 4 Andreas Schwab 2009-08-17 07:59:29 EDT
This is a bug in libcap.

capget(0x20080522, 0, NULL)             = -1 EFAULT (Bad address)
Comment 5 Andreas Schwab 2009-09-21 05:13:55 EDT
*** Bug 524369 has been marked as a duplicate of this bug. ***
Comment 6 Andreas Schwab 2009-09-25 04:29:00 EDT
*** Bug 525309 has been marked as a duplicate of this bug. ***
Comment 7 Eric Paris 2009-10-13 11:59:32 EDT

*** This bug has been marked as a duplicate of bug 525537 ***

Note You need to log in before you can comment on or make changes to this bug.