Bug 517616 - [atlas] atlas-sse instead of atlas-sse2 gets installed on SSE2 capable system
Summary: [atlas] atlas-sse instead of atlas-sse2 gets installed on SSE2 capable system
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: atlas
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 08:05 UTC by Joachim Frieben
Modified: 2010-07-26 18:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-26 18:39:37 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2009-08-15 08:05:08 UTC
Description of problem:
After a fresh install from the current "rawhide" tree, a look at the install.log reveals that package atlas-sse has been installed. The system is a Pentium 4 style one which supports SSE2 according to /proc/cpuinfo:

  processor       : 0
  vendor_id       : GenuineIntel
  cpu family      : 15
  model           : 2
  model name      : Intel(R) Celeron(R) CPU 2.00GHz
  stepping        : 9
  cpu MHz         : 2000.000
  cache size      : 128 KB
  fdiv_bug        : no
  hlt_bug         : no
  f00f_bug        : no
  coma_bug        : no
  fpu             : yes
  fpu_exception   : yes
  cpuid level     : 2
  wp              : yes
  flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
                    cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss
                    ht tm pbe up pebs bts cid xtpr
  bogomips        : 3993.63
  clflush size    : 64
  power management:

Version-Release number of selected component (if applicable):
atlas-3.8.3-7.fc12

How reproducible:
Always.

Steps to Reproduce:
1. Install current Fedora development on Pentium 4 system.
  
Actual results:
Installed ATLAS package only supports SSE but not SSE2.

Expected results:
Installed ATLAS package is the best performing one thus atlas-sse2 when the CPU has the corresponding flag.

Additional info:
This might actually be an anaconda issue. In this case the bug report should be reassigned.

Comment 1 Deji Akingunola 2009-08-30 01:11:34 UTC
I don't understand how this can happen, can you provide more information about what is actually pulling in atlas during installation. 
BTW, I also think this must be anaconda or yum issue rather than atlas packaging bug.

Comment 2 Joachim Frieben 2009-09-07 14:20:31 UTC
# yum install numpy
Loaded plugins: refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package numpy.i686 0:1.3.0-6.fc12 set to be updated
--> Processing Dependency: libatlas.so.3 for package: numpy-1.3.0-6.fc12.i686
--> Processing Dependency: libptcblas.so.3 for package: numpy-1.3.0-6.fc12.i686
--> Processing Dependency: liblapack.so.3 for package: numpy-1.3.0-6.fc12.i686
--> Processing Dependency: libptf77blas.so.3 for package: numpy-1.3.0-6.fc12.i686
--> Running transaction check
---> Package atlas-sse.i686 0:3.8.3-9.fc12 set to be updated
--> Finished Dependency Resolution

Package numpy is installed by default when using the live CD. It appears that the dependency on atlas gets established only indirectly through the shared libraries.
Looking at package names by alphabetical order, atlas-sse precedes atlas-sse2 and gets pulled in which understandable. I wonder whether packages atlas-sse2 or atlas-sse3 do get pulled in automatically on **any** system capable of taking advantage them.
Other systems of mine are a Pentium III-M system for which atlas-sse is the right one. A further Opteron based system simply has package atlas installed which is more or less ok because on x86_64 systems, SSE2 is enabled at the compiler level. However, atlas-sse3 would have to be pulled in by hand, too.
This raises the interesting question how to handle this package selection issue if it were possible at reasonable cost ..

Comment 3 Joachim Frieben 2009-10-04 11:39:48 UTC
Likewise, on a Pentium III-M system, package atlas instead of atlas-sse gets pulled in during install from the current "rawhide" tree. Now that there is a base package atlas for Fedora 11/12 i[5/6]86 (see bug 510498) is there agreement that the decision of choosing the most efficient subpackage atlas-sse, atlas-sse2, .. be up to the user?
In this case, I would close the bug as WONTFIX.

Comment 4 Deji Akingunola 2009-10-04 18:34:48 UTC
(In reply to comment #3)
> Likewise, on a Pentium III-M system, package atlas instead of atlas-sse gets
> pulled in during install from the current "rawhide" tree. Now that there is a
> base package atlas for Fedora 11/12 i[5/6]86 (see bug 510498) is there
> agreement that the decision of choosing the most efficient subpackage
> atlas-sse, atlas-sse2, .. be up to the user?

Essentially, yes.

> In this case, I would close the bug as WONTFIX.

Comment 5 Bug Zapper 2009-11-16 11:27:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.