Bug 517620 - Xchat wants to install additional font Japanese which fails
Summary: Xchat wants to install additional font Japanese which fails
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 09:01 UTC by Dagan McGregor
Modified: 2009-11-17 13:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-17 13:39:38 UTC


Attachments (Terms of Use)

Description Dagan McGregor 2009-08-15 09:01:25 UTC
Description of problem:
Connecting to Freenode network in Xchat, and a prompt appears noting Xchat wants to install a font, Japanese.

"An additional font is required to view this document correctly
Japanese
Do you want to search for a suitable package now?"

It then selects a list of font packages to install, but fails with this dependancy error:
vlgothic-fonts-common = 20090204-3.fc11 is needed by package vlgothic-p-fonts-20090204-3.fc11.noarch (fedora)
vlgothic-fonts-common = 20090204-3.fc11 is needed by package vlgothic-fonts-20090204-3.fc11.noarch (fedora)

Version-Release number of selected component (if applicable):
Name       : xchat
Arch       : x86_64
Epoch      : 1
Version    : 2.8.6
Release    : 11.fc11

Name       : PackageKit
Arch       : x86_64
Version    : 0.4.8
Release    : 2.fc11

Name       : vlgothic-fonts-common
Arch       : noarch
Version    : 20090612
Release    : 1.fc11
Size       : 16 k
Repo       : updates
**NOT INSTALLED**

How reproducible:
Most times connecting to Freenode (defaults to UTC encoding), in #fedora, and few other channels.

Steps to Reproduce:
1. Open Xchat
2. Connect to Freenode
3. Prompt appears for the font, to search or close.
4. Search for font
5. List of packages appears, so click 'Install'
6. Dependancy error appears.

Actual results:
"An additional font is required to view this document correctly
Japanese
Do you want to search for a suitable package now?"

It then selects a list of font packages to install, but fails with this dependancy error:
vlgothic-fonts-common = 20090204-3.fc11 is needed by package vlgothic-p-fonts-20090204-3.fc11.noarch (fedora)
vlgothic-fonts-common = 20090204-3.fc11 is needed by package vlgothic-fonts-20090204-3.fc11.noarch (fedora)

Expected results:
If Xchat has a dependancy for the Japanese font for any reason, this should be installed when Xchat is installed, not when connecting to a network.

Also, the dependancy issue with the vlgothic fonts should not happen, as the vlgothic-fonts-common package is clearly available in the repository.

Additional info:

Comment 1 Kevin Kofler 2009-08-15 11:38:36 UTC
The error is a packaging bug with the vlgothic-fonts, reassigning.

As for the idea of installing fonts from the network, that one also has nothing to do with XChat, but is implemented entirely on the library level:
https://fedoraproject.org/wiki/Features/AutoFontsAndMimeInstaller

Complain to the Pango maintainers if you don't like that feature. There's also an option in some config file to turn it off, but I can't find it now.

Comment 2 Dagan McGregor 2009-08-15 21:51:31 UTC
 Well the pop-up to install a Japanese font is very annoying, because I have never seen any chat in any of the channels that would require a Japanese font to display (they're all English channels!).

 If the default UTC encoding of channels in Xchat requires non-English fonts to display UTC encoding correctly, they need to be included in dependancies.

 And lastly, there is no 'ignore' option to avoid installing fonts that I don't require to view English language channels.

Comment 3 Akira TAGOH 2009-08-17 02:38:01 UTC
What's a packaging bug? "yum install vlgothic-fonts vlgothic-p-fonts" works. apparently AutoFontsInstaller feature doesn't resolve dependencies properly. a subpackage vlgothic-fonts-common are allowed in the font packaging policy. I don't see anything wrong in vlgothic-fonts package here.

Comment 4 Nicolas Mailhot 2009-09-05 15:13:45 UTC
1. If the text stack incorrectly decides to install a japanese font, it's a either a fontconfig (bad definition of japanese glyphs) or pango (bad detection) bug. If there is some japanese to display in (for example in one of the nicks), the autoinstall suggestion is correct

2.  However once it has decided to install a japanese font, if it fails, that's clearly a pk bug

Comment 5 Akira TAGOH 2009-09-07 04:17:54 UTC
Given that it's a package bug, what would you suggest to get it working? I have only idea to stop subpackaging -common though.

Comment 6 Nicolas Mailhot 2009-09-07 05:32:51 UTC
(In reply to comment #5)
> Given that it's a package bug, what would you suggest to get it working? I have
> only idea to stop subpackaging -common though.  

If manual yum install works but PK font autoinstall does not that's not a package bug that's a packagekit bug

Comment 7 Steven M. Parrish 2009-09-13 01:30:00 UTC
Any comments Richard?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 8 Richard Hughes 2009-11-17 13:39:38 UTC
commit b4369cb7084e0690041f62231fc9eb45d9e004bb
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Nov 17 13:38:41 2009 +0000

    Also add xchat to the list of applications we ignore


Note You need to log in before you can comment on or make changes to this bug.