Bug 517658 - gpk-application always starts maximised.
Summary: gpk-application always starts maximised.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 18:35 UTC by Tomasz Chrzczonowicz
Modified: 2009-08-25 21:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 15:53:00 UTC


Attachments (Terms of Use)
PackageKit non-maximised 1280x800 (609.16 KB, image/png)
2009-08-20 16:41 UTC, Tomasz Chrzczonowicz
no flags Details
gpk-application unmaximised after running (1.06 MB, image/png)
2009-08-20 16:45 UTC, Tomasz Chrzczonowicz
no flags Details

Description Tomasz Chrzczonowicz 2009-08-15 18:35:33 UTC
Description of problem:

gpk-application always starts maximised, no matter what.
When I double click the window title bar, it gets shrunk to a minimum and has to be enlarged a bit so that I can actually use it.

Version-Release number of selected component (if applicable):

gnome-packagekit.i586 2.27.3-1.fc11

How reproducible:

Run it from Gnome menu.

Expected results:

If I close it and it's not maximised I think it shouldn't start maximised

Comment 1 Richard Hughes 2009-08-20 15:53:00 UTC
It should if you've got a "small" screen. Else it's pretty much unusable.

Comment 2 Tomasz Chrzczonowicz 2009-08-20 16:41:54 UTC
Created attachment 358132 [details]
PackageKit non-maximised 1280x800

As you can see in the screenshot, windowed PackageKit in this resolution is perfectly usable.

Besides, no other app in Gnome that I know of starts maximised if it was closed while non-maximised. This breaks consistency in user experience and is dishearting.

If someone wants to have an application starting maximised, then such person would just close it maximised, wouldn't he? Why force it upon users?

I understand that you might want it start maximised on the first run, but why force it upon users no matter what?

Comment 3 Tomasz Chrzczonowicz 2009-08-20 16:45:02 UTC
Created attachment 358133 [details]
gpk-application unmaximised after running

That's what I get when I double click the title bar each time after gpk-application starts forcibly maximised. Now, _this_ is unusable.

Comment 4 Tomasz Chrzczonowicz 2009-08-25 21:16:16 UTC
Please at least reconsider it for Fedora 12, since its Nodoka theme seems to have smaller widgets (esp. buttons) and now it is even more usable.


Note You need to log in before you can comment on or make changes to this bug.