Bug 517662 - Dependancies dialog has little space for package list and can't be resized
Summary: Dependancies dialog has little space for package list and can't be resized
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 19:15 UTC by Tomasz Chrzczonowicz
Modified: 2009-08-21 14:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 15:54:06 UTC


Attachments (Terms of Use)
Dependancies dialong in 1280x800 (193.21 KB, image/png)
2009-08-20 16:14 UTC, Tomasz Chrzczonowicz
no flags Details

Description Tomasz Chrzczonowicz 2009-08-15 19:15:28 UTC
Description of problem:

Dependancies dialog has little space for package list and can't be resized.

Version-Release number of selected component (if applicable):

gnome-packagekit.i586 2.27.3-1.fc11

How reproducible:

1. Start gpk-application
2. Select some packages for installation that pull additional dependencies.
3. Click apply
4. Notice that you can propably see only one dependency at a time and can't rezise the dialog window.

Expected results:

The dialog window is resizable and propably it's starting size reflects the number of list of item numbers up to a certain point.

Additional info:

My screen resolution is 1280x800.

Comment 1 Richard Hughes 2009-08-20 15:54:06 UTC
(In reply to comment #0)
> My screen resolution is 1280x800.  

Normally it would be bigger, but because your screen s small the window is not made bigger.

Comment 2 Tomasz Chrzczonowicz 2009-08-20 16:14:38 UTC
Created attachment 358127 [details]
Dependancies dialong in 1280x800

Please look at this screenshot. This is far from usable.

Why prevent people from resizing this window?

Comment 3 Tomasz Chrzczonowicz 2009-08-20 16:19:29 UTC
My screen is not small. It's 15"4 laptop and there's plenty of space to make this window bigger.

Comment 4 Richard Hughes 2009-08-21 14:31:43 UTC
Agreed:

commit ade4632b2013122173ef766255f84301e26a3d31
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Aug 21 15:30:28 2009 +0100

    Resize the deps list in a better way. Fixes rh#517662


Note You need to log in before you can comment on or make changes to this bug.