Bug 517664 - virt-manager ignores "Host does not support any virtualization options" error
virt-manager ignores "Host does not support any virtualization options" error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-08-15 15:41 EDT by jmccann
Modified: 2015-01-14 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-29 15:47:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (38.76 KB, image/png)
2009-08-20 19:59 EDT, jmccann
no flags Details
log file (4.12 KB, text/plain)
2009-08-20 20:01 EDT, jmccann
no flags Details

  None (edit)
Description jmccann 2009-08-15 15:41:58 EDT
Doesn't let me continue from first page of new VM assistant.
Comment 1 Mark McLoughlin 2009-08-19 05:37:36 EDT
Uh, Jon?

version number, ~/.virt-manager/virt-manager.log, what exactly do you mean by "doesn't let me" etc.?

http://fedoraproject.org/wiki/Reporting_virtualization_bugs

It's working fine for me here with virt-manager-0.8.0-1.fc12.noarch
Comment 2 jmccann 2009-08-20 19:59:13 EDT
Created attachment 358176 [details]
screenshot

Oops.  Looks like my screenshot didn't get attached the first time.
Comment 3 jmccann 2009-08-20 20:01:40 EDT
Created attachment 358177 [details]
log file

virt-manager-0.8.0-2.fc12.noarch
Comment 4 Mark McLoughlin 2009-08-21 05:20:42 EDT
Okay, I guess the problem is that you don't have qemu-kvm installed

  ValueError: Host does not support any virtualization options 

But virt-manager should handle this a lot better

bug #513494 has some longer term ideas

In the mean time, though, virt-manager should at least give the user some sort of indication what is wrong
Comment 5 Cole Robinson 2009-09-29 15:47:26 EDT
The error message is set as the tooltip for the grayed out 'install' section. This is confusing, so I changed it to hide the install options and display the error in a label. This is fixed in virt-manager-0.8.0-6.fc12.

Note You need to log in before you can comment on or make changes to this bug.