Bug 517672 - Changes for lowering capabilities project
Changes for lowering capabilities project
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kerneloops (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-15 17:35 EDT by Steve Grubb
Modified: 2011-12-13 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 13:17:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to drop capabilities (1.25 KB, patch)
2009-08-15 17:35 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2009-08-15 17:35:31 EDT
Created attachment 357551 [details]
Patch to drop capabilities

Description of problem:
As part of the lowering capabilities project, we should drop all unnecessary
capabilities in all daemons.
Comment 1 Steve Grubb 2009-09-29 08:51:29 EDT
Any progress on this? Thanks.
Comment 2 Chuck Ebbert 2009-09-30 23:55:48 EDT
Building with that patch applied, I get:

type=AVC msg=audit(1254369329.201:17): avc:  denied  { setpcap } for  pid=1784 comm="kerneloops" capability=8 scontext=system_u:system_r:kerneloops_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kerneloops_t:s0-s0:c0.c1023 tclass=capability

type=SYSCALL msg=audit(1254369329.201:17): arch=c000003e syscall=157 success=no exit=-1 a0=18 a1=0 a2=1 a3=0 items=0 ppid=1783 pid=1784 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kerneloops" exe="/usr/sbin/kerneloops" subj=system_u:system_r:kerneloops_t:s0-s0:c0.c1023 key=(null)
Comment 3 Steve Grubb 2009-10-01 09:50:23 EDT
This is expected since Dan hasn't written policy for anything not in rawhide. Assuming you are in permissive mode, does everything work as its supposed to? Please note that I need this applied before the beta freeze.
Comment 4 Chuck Ebbert 2009-10-01 13:17:00 EDT
Kerneloops has been obsoleted by abrt

Note You need to log in before you can comment on or make changes to this bug.