Bug 517685 - Scan Removable Media in Rythmbox does not see music CD
Scan Removable Media in Rythmbox does not see music CD
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-16 01:52 EDT by Bob Shanteau
Modified: 2009-08-19 12:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 12:09:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Shanteau 2009-08-16 01:52:22 EDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

After inserting a music CD and opening Rythmbox, the CD is not recognized and selecting Scan Removable Media has no effect.

Reproducible: Always

Steps to Reproduce:
1. Install Rawhide from boot.iso dated 8/15/2009.
2. Reboot to desktop.
3. Insert music CD.
4. Open Rythmbox.
5. Select Scan Removable Media from menu.
Actual Results:  
No effect.

Expected Results:  
Tracks on CD listed.
Comment 1 Matthias Clasen 2009-08-16 22:02:06 EDT
Probably more a gvfs problem
Comment 2 Tomáš Bžatek 2009-08-17 07:42:26 EDT
The problem is missing gvfsd-cdda mount here. Nautilus can handle autorun if running and can mount it automatically, otherwise you will not get any cdda mounts on insertion. Apparently Rhythmbox doesn't mount it itself, even though the content is detected without mounting.


Drive(0): ATAPI DVD A  DH16A6L
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sr0'
  themed icons:  [drive-optical]  [drive]
  is_media_removable=1
  has_media=1
  is_media_check_automatic=1
  can_poll_for_media=1
  can_eject=1
  can_start=0
  can_stop=0
  start_stop_type=unknown
  Volume(0): Audio Disc
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     unix-device: '/dev/sr0'
    activation_root=cdda://sr0/
    themed icons:  [media-optical-audio]  [media-optical]  [media]
    can_mount=1
    can_eject=1
    should_automount=1
Comment 3 Matthias Clasen 2009-08-17 10:22:52 EDT
Might be fixed by 

http://cgit.freedesktop.org/DeviceKit/DeviceKit-disks/commit/?id=cb39d9c3829939eda833a2e3508d91f2561ff26c

which will hit rawhide with the next DeviceKit-disks release later today.
Comment 4 Matthias Clasen 2009-08-19 01:32:06 EDT
Indeed, automounting and starting of rhythmbox works now. But rhythmbox itself doesn't handle the audio cd right, it doesn't select it and does not start playing it. 

ps shows that rhythmbox is run as follows:

rhythmbox /home/mclasen/.gvfs/cdda mount on sr0/
Comment 5 Bastien Nocera 2009-08-19 06:57:51 EDT
This is a side-effect of:
http://bugzilla.gnome.org/show_bug.cgi?id=528670
Comment 6 Bastien Nocera 2009-08-19 12:09:32 EDT
Fix is building in rawhide.

Note You need to log in before you can comment on or make changes to this bug.