Bug 517688 - Button on Install FIrmware prompt has no effect
Summary: Button on Install FIrmware prompt has no effect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 06:08 UTC by Bob Shanteau
Modified: 2009-08-20 15:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 15:39:19 UTC


Attachments (Terms of Use)
Console output as requested (7.38 KB, text/plain)
2009-08-18 21:45 UTC, Bob Shanteau
no flags Details

Description Bob Shanteau 2009-08-16 06:08:55 UTC
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

With Hauppauge HVR-1600 card installed, a window appears in lower right of desktop with button saying: Install Firmware. Selecting this button has no effect.

Reproducible: Always

Steps to Reproduce:
1. Insert Hauppauge HVR-1600 card.
2. Install Rawhide from boot.iso dated 8/15/2009.
3. Reboot to desktop.
4. After a minute or two, a dialog box appears with button: Install Firmware.
4. Select Install Firmware button.
Actual Results:  
No effect.

Expected Results:  
Firmware is installed.

Comment 1 Jarod Wilson 2009-08-17 16:32:31 UTC
So far as I know, this is a PackageKit problem, not the firmware package's problem. The firmware package is nothing more than a package with a firmware file in it, some part of PackageKit is, as I understand it, supposed to figure out which package contains the necessary firmware and install it.

Comment 2 Richard Hughes 2009-08-18 09:19:09 UTC
Can you log out, and then back in, and then open a console and do:

killall gpk-update-icon
gpk-update-icon --verbose

And then wait for the bubble about firmware. Then click install, and wait for a few minutes. Then post the entire log to this bugreport as an attachment. Thanks.

Comment 3 Bob Shanteau 2009-08-18 21:45:11 UTC
Created attachment 357856 [details]
Console output as requested

Comment 4 Richard Hughes 2009-08-19 08:02:46 UTC
Ahh, you're using rawhide. The problem is that the firmware installer can only install signed packages at the moment, and normally all the firmware packages are signed. Rawhide is completely unsigned.

Whilst this would "just work" with F12 release, we should probably make this work with rawhide, with an additional password prompt.

Comment 5 Richard Hughes 2009-08-19 11:12:23 UTC
Okay, I've been hacking on GpkFirmware all morning:

commit 7becfa208eb03f13498402a565e33983d4cee9ef
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 12:09:35 2009 +0100

    Enhance GpkFirmware by only asking to replug hardware (rather than reboot) if it is hotpluggable
    
    This functionality also requires GUdev to work correctly.

:100644 100644 0475d3d... 5f69792... M	src/gpk-firmware.c

commit 2d5f685c8541521ed8b7cf36947afe61809e90b1
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 12:06:58 2009 +0100

    Add GUdev libraries if they are available

:100644 100644 84043e7... cbd9867... M	src/Makefile.am

commit fd1baf9c9eaabf9c00c0f88b18aadf84032d812e
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 12:06:05 2009 +0100

    Add optional GUdev configure check

:100644 100644 e0bf963... 2122852... M	configure.ac

commit 8e2cf2e195e0ff95d9db8ca3c5af08440f9a5780
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 10:26:04 2009 +0100

    Allow GpkFirmware to install untrusted, and add a notification to reboot when firmware has been installed

:100644 100644 2f29165... 0475d3d... M	src/gpk-firmware.c

commit 2f76aab9e215195208c4cd7e4cc42cb96cc51031
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 10:20:11 2009 +0100

    Add CanStop and CanRestart methods on the ConsoleKit helper

:100644 100644 71e931f... 9c0f326... M	src/egg-console-kit.c
:100644 100644 fb109ff... 3474cef... M	src/egg-console-kit.h

commit 96775dae196f9ce19010a38fbaa6adcc51b7ada9
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 09:37:36 2009 +0100

    Show errors when using the firmware client, don't just silently fail

:100644 100644 e55ae5a... 2f29165... M	src/gpk-firmware.c

commit 5786f0f5e5e372c4e1b38651b9942f101626f468
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 19 09:36:57 2009 +0100

    Only return newest available packages when we request firmware

:100644 100644 2b06354... e55ae5a... M	src/gpk-firmware.c

Comment 6 Richard Hughes 2009-08-20 15:39:19 UTC
Fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.