Bug 51769 - NTP does not synchornize with True Time NTS and CISCO Routers which are servers.
NTP does not synchornize with True Time NTS and CISCO Routers which are servers.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ntp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 17:59 EDT by Hughes Network Linux
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 10:46:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "strace -s 2048 ntpdate 125.254.254.141 &>ntpdate.log " (18.70 KB, text/plain)
2001-10-25 14:31 EDT, anu
no flags Details

  None (edit)
Description Hughes Network Linux 2001-08-14 17:59:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
The NTPDATE command works fine on Solaris and HP's and Synchronizes with
the
NTS server we have in our network. The same thing does not work on Linunx
7.0, 
2.2.16-22 Kernel. NTP version #ntpd 4.0.99j.  The same NTPD is able to
synchronizes
with external servers on the internet like ntp.cmr.gov. The NTP config file
has the 
server IP address set. NTPDC , sysinfo does not show the correct server
address it is
synchronizing with , instead shows 0.0.0.0.
Please find attached ntp.conf file...
#
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
#server 127.0.0.1       # local clock
#fudge  127.0.0.1 stratum 10

#This is the preferred lab server
server  125.254.254.141 
#server ntp.cmr.gov


#server 128.250.36.2  
#server 200.49.40.1  

#dummy server for testing
#server 130.43.2.2


# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.

driftfile /etc/ntp/drift
#multicastclient
broadcastdelay 0.008


# Authentication delay.  If you use, or plan to use someday, the
# authentication facility you should make the programs in the auth_stuff
# directory and figure out what this number should be on your machine.

authenticate no

#Command to restart ntpd
# /sbin/service ntpd reload
***********End of NTP.conf file*******************************

The NTPDC:sysinfo command show the peer server it is synchronizing as
0.0.0.0
Please see the below output
*********************************************************
ntpdc> sysinfo
system peer:          0.0.0.0
system peer mode:     unspec
leap indicator:       11
stratum:              16
precision:            -17
root distance:        0.00000 s
root dispersion:      0.01941 s
reference ID:         [0.0.0.0]
reference time:       00000000.00000000  Thu, Feb  7 2036  1:28:16.000
system flags:         monitor ntp kernel stats kernel_sync 
jitter:               0.000000 s
stability:            0.000 ppm
broadcastdelay:       0.007996 s
authdelay:            0.000000 s
************************************************************************
We tried stopping the ntpd service and run the ntpdate command on the
command line with the IP address of the server "ntpdate  125.254.254.141"
This command returns the following error:
"No server suitable for synchronization found"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ntpdate <server IP address>
2. /sbin/service ntpd start and look at the /var/log/messages.
The service seems to start without any errors.
3. ntpdc at command line and the execute the sysinfo command at the ntpdc
prompt.
	ntpdc > sysinfo
The system peer line shows 0.0.0.0 as the IP address of the server instead
of the IP address of the server that is set in the ntp.conf file.

Additional info:
Comment 1 Harald Hoyer 2001-08-21 11:07:46 EDT
Hmm, ntpdate seems to work perfectly...

# ntpdate state.de.uu.net
21 Aug 17:10:33 ntpdate[16627]: adjust time server 193.96.65.85 offset 0.005103
sec
# rpm -q ntp
ntp-4.0.99j-7

May it be, that there is any firewall involved?

Please attach the output (ntpdate.log) of 
# strace -s 2048 ntpdate 125.254.254.141 &>ntpdate.log

Comment 2 Harald Hoyer 2001-09-04 05:21:47 EDT
could you please retry with ntp-4.1.0-3 ?
Comment 3 anu 2001-10-25 14:31:41 EDT
Created attachment 35101 [details]
output of "strace -s 2048 ntpdate 125.254.254.141 &>ntpdate.log "
Comment 4 anu 2001-10-25 14:34:57 EDT
Harald 
Hope you received the logs. The NTS server that we use is version 3 and the
version of ntpd on the linux installations is based on version 4. Would using a
version 3 server and a version 4 client cause any problems ? 
Thanks
Anu
Comment 5 anu 2001-10-26 10:46:15 EDT
Harald
We found that NTP does not work because the server is V3.0 and client is
ntpd(v4.0) ...

The command -- <ntpdate -o 3.0 'server ip' > works fine - Is there some way we
can start ntpd to work as a version 3 client ?
Comment 6 Harald Hoyer 2001-10-26 11:56:05 EDT
how about adding to ntp.conf:
version 3
Comment 7 Harald Hoyer 2001-10-26 11:57:29 EDT
i mean e.g.:
server  125.254.254.141  version 3

Note You need to log in before you can comment on or make changes to this bug.