Bug 517729 - When starting my psc1315 all-in-one device SELinux is giving me an AVC Denial, although I can use the printer and the scanner.
Summary: When starting my psc1315 all-in-one device SELinux is giving me an AVC Denial...
Keywords:
Status: CLOSED DUPLICATE of bug 516078
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 12:21 UTC by Fabian
Modified: 2009-08-16 17:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-16 17:10:15 UTC


Attachments (Terms of Use)
SElinux AVC Denial (2.53 KB, text/plain)
2009-08-16 12:22 UTC, Fabian
no flags Details

Description Fabian 2009-08-16 12:21:53 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2

The scanner is working although the SELinux message.
My hplip version is(from yum info hplip):
Name       : hplip
Arch       : x86_64
Version    : 3.9.8
Release    : 2.fc11
Size       : 9.3 M
Repo       : installed
Summary    : HP Linux Imaging and Printing Project
URL        : http://hplip.sourceforge.net/
License    : GPLv2+ and MIT
Description: The Hewlett-Packard Linux Imaging and Printing Project provides
           : drivers for HP printers and multi-function peripherals.
SELinux prevents python(hplip_t)"read" var_lib_t

Reproducible: Always

Steps to Reproduce:
1.Plug in the psc 1315 device and activate it
2.open sane and scan something
3.
Actual Results:  
After step 1 SELinux prints an SELinux AVC Denial. Although the scanner works when doing step2.

Expected Results:  
Scanning shouldnt be possible, at least I think so.

Comment 1 Fabian 2009-08-16 12:22:51 UTC
Created attachment 357569 [details]
SElinux AVC Denial

Comment 2 Tim Waugh 2009-08-16 17:10:15 UTC

*** This bug has been marked as a duplicate of bug 516078 ***


Note You need to log in before you can comment on or make changes to this bug.