Bug 517735 - Subfolders are not visible
Summary: Subfolders are not visible
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 13:15 UTC by Dimitri Papadopoulos
Modified: 2018-04-11 07:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 23:05:01 UTC


Attachments (Terms of Use)
The "abonnements" subfolder is not visible in Fedora 11. (46.40 KB, image/png)
2009-08-16 13:15 UTC, Dimitri Papadopoulos
no flags Details
The "abonnements" subfolder is visible in Windows. (132.12 KB, image/png)
2009-08-16 13:16 UTC, Dimitri Papadopoulos
no flags Details
The "abonnements" subfolder is visible with 3.0b2. (113.49 KB, image/png)
2009-08-17 17:47 UTC, Dimitri Papadopoulos
no flags Details
The "abonnements" subfolder is not visible with 3.0b3. (47.23 KB, image/png)
2009-08-17 17:47 UTC, Dimitri Papadopoulos
no flags Details


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 511007 None None None Never

Description Dimitri Papadopoulos 2009-08-16 13:15:46 UTC
Created attachment 357574 [details]
The "abonnements" subfolder is not visible in Fedora 11.

Description of problem:
Some subfolders are not visible within my Gmail account (IMAP access).
This is a new problem, it happened after upgrading RPM packages yesterday (August 15th). The problem was not visible before July 15th.
This problem is not reproduced under Windows with Thunderbird 3.0b3.

Version-Release number of selected component (if applicable):
3.0-2.6.b3.fc11

How reproducible:
Always.

Steps to Reproduce:
1. View a Gmail account via IMAP.
2. Try to view subfolders.
  
Actual results:
Subfolders are not visible.

Expected results:
Subfolders are visible.

Additional info:
I've tried reproducing the problem with non Gmail accounts without success. The problem is not necessarily with Gmail though, it could be a problem with existing subfolders vs. new subfolders.
In any case I wasn't able to reproduce the problem with the same Gmail account on Windows.

Comment 1 Dimitri Papadopoulos 2009-08-16 13:16:38 UTC
Created attachment 357575 [details]
The "abonnements" subfolder is visible in Windows.

Comment 2 Matěj Cepl 2009-08-17 11:16:33 UTC
Cannot reproduce here ... could you reproduce with the latest upstream binary from ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/ ? 

Otherwise looks like a duplicate of bug 517813.

Comment 3 Dimitri Papadopoulos 2009-08-17 11:58:15 UTC
I'm unable to reproduce the problem with two non-Gmail accounts (Microsoft Exchange IMAP4 service) with lots of subfolders.

I'll try again with the Gmail account and the latest upstream binary ASAP.

Comment 4 Dimitri Papadopoulos 2009-08-17 17:42:43 UTC
I've tried the following versions of Thunderbird:
ftp://ftp.mozilla.org/pub/thunderbird/releases/3.0b2/linux-i686/fr/thunderbird-3.0b2.tar.bz2
ftp://ftp.mozilla.org/pub/thunderbird/releases/3.0b3/linux-i686/fr/thunderbird-3.0b3.tar.bz2
ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/thunderbird-3.0b4pre.en-US.linux-i686.tar.bz2

I can reproduce the problem with 3.0b3 and 3.0b4pre.
I cannot reproduce it with 3.0b2.

Note that the user interface has changed between 3.0b2 and 3.0b3: 3.0b2 uses a cross in a square in front of folders with subfolders, while 3.0b3 uses a triangle/arrow. This change might be related to the problem.

Is there something else you would like me to try?

Comment 5 Dimitri Papadopoulos 2009-08-17 17:47:08 UTC
Created attachment 357683 [details]
The "abonnements" subfolder is visible with 3.0b2.

Comment 6 Dimitri Papadopoulos 2009-08-17 17:47:40 UTC
Created attachment 357684 [details]
The "abonnements" subfolder is not visible with 3.0b3.

Comment 7 Matěj Cepl 2009-08-17 23:05:01 UTC
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=511007) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Comment 8 Matěj Cepl 2009-08-18 10:05:56 UTC
Please join the upstream bug, there is more information requested from you by the upstream developers.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.