Bug 517758 - iostat -n causes stack smashing
Summary: iostat -n causes stack smashing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sysstat
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 517757
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 19:56 UTC by Steve Dickson
Modified: 2012-08-08 13:19 UTC (History)
1 user (show)

Fixed In Version: 8.0.4-8.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of: 517757
Environment:
Last Closed: 2010-01-04 21:20:42 UTC


Attachments (Terms of Use)
Patch that fixes the problem (1.08 KB, patch)
2009-08-16 19:58 UTC, Steve Dickson
no flags Details | Diff

Description Steve Dickson 2009-08-16 19:56:44 UTC
+++ This bug was initially created as a clone of Bug #517757 +++

Description of problem:
When the '-n' flag given (to show NFS mounts) the command
crashes with a stack smashing detected

Version-Release number of selected component (if applicable):
sysstat-9.0.4

How reproducible:
type 'iostat -n'

Steps to Reproduce:
1.
2.
3.
  
Actual results:
*** stack smashing detected ***: iostat terminated
======= Backtrace: =========
/lib/libc.so.6(__fortify_fail+0x48)[0xc37bd8]
/lib/libc.so.6(__fortify_fail+0x0)[0xc37b90]
iostat[0x804d100]
iostat[0x804c185]
iostat[0x804c402]
/lib/libc.so.6(__libc_start_main+0xe6)[0xb56a66]
iostat[0x8048d21]
======= Memory map: ========
00665000-0068f000 r-xp 00000000 fd:00 264662     /lib/libgcc_s-4.4.0-20090506.so.1
0068f000-00690000 rw-p 00029000 fd:00 264662     /lib/libgcc_s-4.4.0-20090506.so.1
00b1c000-00b3c000 r-xp 00000000 fd:00 262268     /lib/ld-2.10.1.so
00b3c000-00b3d000 r--p 0001f000 fd:00 262268     /lib/ld-2.10.1.so
00b3d000-00b3e000 rw-p 00020000 fd:00 262268     /lib/ld-2.10.1.so
00b40000-00cab000 r-xp 00000000 fd:00 262397     /lib/libc-2.10.1.so
00cab000-00cac000 ---p 0016b000 fd:00 262397     /lib/libc-2.10.1.so
00cac000-00cae000 r--p 0016b000 fd:00 262397     /lib/libc-2.10.1.so
00cae000-00caf000 rw-p 0016d000 fd:00 262397     /lib/libc-2.10.1.so
00caf000-00cb2000 rw-p 00caf000 00:00 0 
00fb0000-00fb1000 r-xp 00fb0000 00:00 0          [vdso]
08048000-08050000 r-xp 00000000 fd:01 1431245    /usr/bin/iostat
08050000-08051000 rw-p 00008000 fd:01 1431245    /usr/bin/iostat
0965f000-09680000 rw-p 0965f000 00:00 0          [heap]
b7d7e000-b7d7f000 r--p 024c6000 fd:01 1886787    /usr/lib/locale/locale-archive
b7d7f000-b7dbb000 r--p 0246d000 fd:01 1886787    /usr/lib/locale/locale-archive
b7dbb000-b7fbb000 r--p 00000000 fd:01 1886787    /usr/lib/locale/locale-archive
b7fbb000-b7fbd000 rw-p b7fbb000 00:00 0 
bf929000-bf93e000 rw-p bffeb000 00:00 0          [stack]
Aborted (core dumped)


Expected results:
Normal output... 

Additional info:

--- Additional comment from steved@redhat.com on 2009-08-16 15:51:46 EDT ---

Created an attachment (id=357586)
Patch that fixes the problem

--- Additional comment from steved@redhat.com on 2009-08-16 15:53:02 EDT ---

Ivana, if want to give me cvs access to this package I'll make the commit myself.

Comment 1 Steve Dickson 2009-08-16 19:58:06 UTC
Created attachment 357587 [details]
Patch that fixes the problem

Comment 2 Ivana Varekova 2009-08-17 10:39:55 UTC
Hello,
please could you attach here file
/proc/self/mountstats
from affected system?

Comment 3 Steve Dickson 2009-08-17 15:10:48 UTC
There was nothing special about contents of /proc/self/mountstats
although I did have the NFS server (via service nfs start).

Comment 4 Ivana Varekova 2009-11-30 10:26:34 UTC
Please, do you have a test case for the problem you report?

Comment 5 Fedora Update System 2009-12-11 11:05:35 UTC
sysstat-8.0.4-8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/sysstat-8.0.4-8.fc11

Comment 6 Steve Dickson 2009-12-15 13:34:35 UTC
it works for me! Thank you!

Comment 7 Fedora Update System 2009-12-16 01:12:54 UTC
sysstat-8.0.4-8.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sysstat'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13187

Comment 8 Fedora Update System 2010-01-04 21:20:37 UTC
sysstat-8.0.4-8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.