Bug 51778 - up2date fails with "500: "Server Error""
up2date fails with "500: "Server Error""
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 20:30 EDT by Need Real Name
Modified: 2015-01-07 18:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 09:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copy of /etc/sysconfig/rhn/up2date (1.85 KB, text/plain)
2001-08-14 21:29 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-08-14 20:30:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
up2date -u results in a "500: "Server Error"" message while getting the
list of available packages. This happens only on the Roswell public beta
release ( 7.1.93). Other machines,and even the same machine running Seawolf
(RH 7.1) work properly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date -p (also happens when running the GUI up2date)
2.
3.
	

Actual Results:  [root@roswell root]# up2date -u
 
Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:
500: "Server Error" while attempting to get
$RHN/redhat-linux-i386-7.1.93/listPackages/20010808075423

Expected Results:  Available packages should be downloaded and installed).

Additional info:

This issue has been discussed at some length on the Roswell mailing list.
Only posting it here to make it 'official' as I don't see the same problem
in bugzilla yet. And, well, if it's not in bugzilla...
Comment 1 Need Real Name 2001-08-14 20:33:15 EDT
In the steps to reproduce portion above:

up2date -p should read up2date -u
Comment 2 Adrian Likins 2001-08-14 21:08:18 EDT
Well, dont see any 500's on the app server, but we were having some
issues with the proxy servers earlier today, which might explain it.

It seems to work fine from here. Is this still causing problems?
Comment 3 Jay Turner 2001-08-14 21:15:44 EDT
If you are still having problems with the site, please post your
/etc/sysconfig/rhn/up2date file as an attachment to this bug report so that we
can better replicate the setup in the test lab.  Thanks.
Comment 4 Need Real Name 2001-08-14 21:24:27 EDT
Yes, It is still happening. This has happened since installing 'Roswell'.If I
boot 'Seawolf' up2date works fine.
I can provide up2date logs, IP information, or anything else you need. The error
text I pasted into the report was from the time of the report.
This might help when searching the logs:
[root@roswell root]# date ; up2date -u ; date
Tue Aug 14 21:25:55 EDT 2001

Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:
500: "Server Error" while attempting to get
$RHN/redhat-linux-i386-7.1.93/listPackages/20010808075423

[root@roswell root]# tail /var/log/up2date

[Tue Aug 14 21:25:57 2001] up2date logging into up2date server
[Tue Aug 14 21:25:57 2001] up2date successfully retrived authentication token
from up2date server
[Tue Aug 14 21:25:57 2001] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Tue Aug 14 21:25:57 2001] up2date getAvailablePackageList from network
[Tue Aug 14 21:25:57 2001] up2date see if we need to login again
[Tue Aug 14 21:25:57 2001] up2date A protocol error occured: 500: "Server Error"
while attempting to get
$RHN/redhat-linux-i386-7.1.93/listPackages/20010808075423 , attempt #1
Comment 5 Need Real Name 2001-08-14 21:29:14 EDT
Created attachment 27854 [details]
copy of /etc/sysconfig/rhn/up2date
Comment 6 Adrian Likins 2001-08-14 21:55:58 EDT
Or you talking though a local proxy?

there is at least one known bug with local proxies that
might cause problems.
Comment 7 Need Real Name 2001-08-14 22:42:52 EDT
I am not going through a local proxy.
My ISP does appear to proxy http connections.
Most sites that attempt to determine my IP address (dyndns.org, for example) get
it wrong. I believe they are getting the address of the ISP's proxy machine.
Comment 8 Adrian Likins 2001-08-15 21:10:32 EDT
okay, just tracked down the proxy bug, and have it fixed. 
Need to run it though qa first to verify.
Comment 9 vrossum 2001-08-16 17:58:34 EDT
I upgraded to rpm 4.0.3 (needed for KDE 2.2) and now get the same error.
 
So that might also be the difference above between Roswell and 7.1
Comment 10 Need Real Name 2001-08-22 01:19:30 EDT
Upgrading the following packages:
python-xmlrpc-1.4.7-1.i386.rpm
up2date-2.6.0-7.x.31
from http://people.redhat.com/jturner/software.html
Solved this problem. up2date now works fine.
Comment 11 Jay Turner 2001-08-22 09:27:46 EDT
Closing this issue out.

Note You need to log in before you can comment on or make changes to this bug.