Bug 517800 - Activate VPN automatically when connected to specific network
Activate VPN automatically when connected to specific network
Status: CLOSED DUPLICATE of bug 483120
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-17 04:58 EDT by Michael Monreal
Modified: 2009-11-06 23:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 23:37:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2009-08-17 04:58:23 EDT
It would be really helpful if the VPN config dialog had the option to start the VPN automatically as soon as you connect to a given network. E.g. also activate the company's VPN as soon as you connect to $configured_lan or $configured_wlan.
Comment 1 Kieran Clancy 2009-09-10 03:25:48 EDT
I'd like to add my support for this feature. At work for example everyone needs to connect to the VPN to access the network (because the wireless is unprotected), so I want to connect to that VPN if and only if I'm on that network.

In these cases, NetworkManager should not consider itself to be "online" until the VPN is up as well as the physical network. (Currently, my browser will go "online" once the wireless is connected, even though I can't access the internet or local network until the VPN is active.

I actually think the best place to put these options is in the Wired/Wireless connections options (not the VPN config dialog, because of the one-to-many relationship between VPNs and physical networks). Perhaps a VPN tab in the connection editing dialog like this:

 ______________
/ VPN Settings \
---------------------------------------------------
|                                                 |
| [x] Automatically connect to VPN: [Work     |v] |
|                                                 |
|                                                 |
|                                                 |
|                                                 |
---------------------------------------------------
Comment 2 Dan Williams 2009-11-06 23:37:06 EST
duped to bug #483120, the fix for this will also be the fix for that.

*** This bug has been marked as a duplicate of bug 483120 ***
Comment 3 Kieran Clancy 2009-11-06 23:50:34 EST
I do not think that this is a duplicate of bug 483120. That bug is about always automatically connecting to a certain VPN. This is not what I want. This bug is about associating a VPN with specific networks.

When I am at home, I don't want to connect to my work's VPN automatically. When I am at work, I _always_ want to connect to it.

Note You need to log in before you can comment on or make changes to this bug.