Bug 517843 - Recent Documents for OOo and GNOME are different
Summary: Recent Documents for OOo and GNOME are different
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 13:09 UTC by Dwayne Bailey
Modified: 2009-08-31 23:32 UTC (History)
1 user (show)

Fixed In Version: 3.1.1-19.1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 23:32:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 104306 None None None Never

Description Dwayne Bailey 2009-08-17 13:09:36 UTC
Description of problem:
The recent documents displayed in GNOMEs Places->Recent Documents is different from the list in OpenOffice.org's File->Recent Documents

Version-Release number of selected component (if applicable):
3.1.0-11.3.fc11

How reproducible:
Always, just open a number of OOo files

Expected results:
This list in GNOME matches that in OOo


Additional info:
The GNOME list seems to be pulled from ~/.recently-used while GNOME is coming from ~/.recently-used.xbel

I think the first is the freedesktop 'standard', while the second seems to be where GNOME is using the more generic bookmark standard.

The first does reflect what I see in OOo and the second what I'm seeing on GNOME.

Not sure how hard it would be to make OOo write to the the XBEL file rather then the other one.

Comment 1 Caolan McNamara 2009-08-17 13:48:43 UTC
Hmm, this should have worked. We dlsym open up the gtk functions to read/write the recently used files. But the dysym fails these days for some reason, linking the lib directly to libgtk and then dlsyming works fine, so this is hackable back in at least. Though I guess best thing would be to move this stuff out of "shell" and into vcl itself which would be a better place for it.

Comment 2 Caolan McNamara 2009-08-18 07:49:15 UTC
Will be fixed in >= 3.1.0-11.6

Comment 3 Fedora Update System 2009-08-29 09:41:50 UTC
openoffice.org-3.1.1-19.1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.1.fc11

Comment 4 Fedora Update System 2009-08-31 23:32:11 UTC
openoffice.org-3.1.1-19.1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.