Bug 517910 - Usability problems saving with gnome-screenshot
Summary: Usability problems saving with gnome-screenshot
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 20:15 UTC by Christopher Beland
Modified: 2010-12-05 06:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-05 06:35:35 UTC


Attachments (Terms of Use)

Description Christopher Beland 2009-08-17 20:15:30 UTC
I hit the "Print Screen" button on my keyboard, and a dialog box popped up, containing a thumbnail of the successful screenshot, and two fields.  "Name:" is a text entry field, and "Save in folder:" is a pull-down.  At first, I selected /tmp/mbta-screenshot.png using the graphical interface for the latter.  But this is a filename, not a folder, so (1) I shouldn't have been allowed to select this.

I changed the folder selection to /tmp using the graphical interface, and entered "mbta-screenshot.png" in the "Name:" field.  Upon hitting save, I got the error:

 Impossible to save the screenshot to file:/mbta-screenshot.png.
 Error was Error opening file '/mbta-screenshot.png': Permission denied.
 Please choose another location and retry.

(2) "Impossible to save" is not good grammar; "Could not save" would be better.  "Error was" could probably use a colon to separate it from the actual error message. 

(3) It should have attempted to save to /tmp/mbta-screenshot.png, not /mbta-screenshot.png.

If I attempt this procedure and supply "Screenshot.png" for "Name:" and "/tmp/test.png" for "Save in folder:", then /tmp/test.png is created as a directory, and the image gets saved to /tmp/Screenshot.png.

Version:
gnome-utils-2.26.0-1.fc11.i586

Comment 1 Christopher Beland 2009-10-27 13:48:45 UTC
With gnome-utils-2.28.1-2.fc12.i686, problem (1) is solved; I can no longer select a file in the GUI when I should be selecting a directory.  Problem (3) is solved; the interface now works OK as long as I don't put a / in the Name: field.  But (4) it would be nice if I could specify an absolute path there, though, like I can in the Firefox "Save As" dialog.  Instead, if I put /tmp/test.png in the Name: Field, I get an error which still has grammatical problems as mentioned under (2).

Comment 2 Bug Zapper 2009-11-16 11:31:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Bug Zapper 2010-11-04 10:28:06 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2010-12-05 06:35:35 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.