Bug 517920 - No Sound after update from Fedora 9
Summary: No Sound after update from Fedora 9
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 21:24 UTC by j.fedora.20.jbulling
Modified: 2009-10-14 22:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 22:02:24 UTC


Attachments (Terms of Use)

Description j.fedora.20.jbulling 2009-08-17 21:24:23 UTC
Description of problem:
I updated my Fedora 9 installation to Fedora 11 useing a downloaded DVD-image (i386 on a Athlon 64 platform). The previous installation was Fedora 9 i386.

In my Fedora 9 environment sound was working. After the update the sound didn't work anymore. Neither mplayer nor the system sounds (e.g. during startup) were produced.
I guess this is a installation problem, so I assigned it to anaconda.

Version-Release number of selected component (if applicable):
Version of the DVD-image i386 which was on fedoras homepage on Saturday night (I guess the most recent one).

How reproducible:
The sound isnt hearable all the time. Reboot doesnt fix anything. Also a yum-updated didnt fix it

Steps to Reproduce:
1. Take an existing FC9 installation
2. Update the system useing a FC11 DVD i386
3. Restart => greeting sound is not hearable during startup
4. Start mplayer => no sound is hearable
  
Actual results:
No sound is hearable

Expected results:
Sound works

Additional info:

Comment 1 Chris Lumens 2009-08-18 14:04:58 UTC
There are so many things that could be the problem here, and anaconda does nothing specific to sound.  Let's at least reassign to a sound-related component for investigation.

Comment 2 Lennart Poettering 2009-08-19 14:45:07 UTC
Please be more specific. What doesn't work? Is not sound card detected? Does the volume control show a device?  What' it named? Maybe the volume is just too low?

Comment 3 j.fedora.20.jbulling 2009-08-19 16:40:33 UTC
The tool tip for "Volume control" shows "internal device.
No the volume is surely not only too low. As I said it worked in version FC9 and I didn't change the hardware since than. It hasn't worked since I updated to FC11 so I think it is an error in the installation/update scripts.

Please let me know if you need more information. I remember there was a tool to list the pci bus to list the device names, but it seems to be removed.

But could you do me one favour please? Don't complain about missing info if you don't tell me what you need and how to get it. How could I know if my sound card was detected, if the upgrade process works outomatically without giving feedback?
I also can't find a hardware browser. There was one in ealier versions of fedora. Where has it gone? Isn't it installed automatically anymore?

But keep in mind, sound worked in FC9 on the same machine. It was automatically detected in FC9, automatically installed and activated during the initial installation.

Is it possible that some kernel module containing the driver was not installed or was renamed in the new kernel?

Comment 4 Lennart Poettering 2009-08-19 17:03:14 UTC
If the applet shows that "Internal Audio" was properly identified that everything works properly.

This is most likely just a mixer initialization problem.

Please open a terminal and try "alsactl init". Does that fix audio? If not, could you run "alsamixer -c0" in the same terminal and play around with it? Any luck finding a control that fixes audio for you?

Comment 5 j.fedora.20.jbulling 2009-08-19 20:28:10 UTC
After performing these steps it worked, only the headphones still don't work. They are still plugged in as they were before I upgraded to FC11 and worked before.

Comment 6 Lennart Poettering 2009-08-24 02:36:30 UTC
Have you player around with "alsamixer -c0 in a terminal"? Any luck?

Comment 7 Lennart Poettering 2009-10-14 22:02:24 UTC
Closing due to lack of response.


Note You need to log in before you can comment on or make changes to this bug.