Bug 517938 - Cannot install KVM guests over NFS (rtl8139 emulation)
Cannot install KVM guests over NFS (rtl8139 emulation)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Lawrence Lim
: Reopened
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-08-17 22:50 EDT by Gary Case
Modified: 2014-03-25 21:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 15:17:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virsh dumpxml 1 from system RHEL5.4 system exhibiting NFS mount problem (1.37 KB, text/plain)
2010-02-12 13:54 EST, Gary Case
no flags Details
visrh dumpxml 1 from RHEL5.5 beta system that works correctly (1.45 KB, text/plain)
2010-02-12 15:35 EST, Gary Case
no flags Details

  None (edit)
Description Gary Case 2009-08-17 22:50:02 EDT
Description of problem:
For some reason, KVM install attempts of RHEL5.4 on RHEL5.4 will not succeed if an NFS mount is used as the install source. 

Version-Release number of selected component (if applicable):
RHEL5.4 x86_64 -162 kernel
kvm-83-105.el5

How reproducible:
Every time

Steps to Reproduce:
1. Run virt-manager
2. Install a new KVM guest
3. Use NFS URL as install source 
4. Wait for a very very long time with no installed system
  
Actual results:
on screen F4, these messages repeated over and over again
server $SERVERNAME not responding, till trying
server $SERVERNAME not responding, till trying
server $SERVERNAME OK
server $SERVERNAME OK
server $SERVERNAME OK
server $SERVERNAME not responding, till trying
server $SERVERNAME not responding, till trying
server $SERVERNAME not responding, till trying
server $SERVERNAME OK
server $SERVERNAME not responding, till trying

Expected results:
Normal install

Additional info:
I have a machine that can reproduce this easily.
Comment 2 Dor Laor 2009-10-29 18:14:02 EDT
Did you suffer from network issues? Does it still happen?
It's a very common use case so I doubt it happens now.
Comment 3 RHEL Product and Program Management 2009-10-29 18:26:59 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 8 Eduardo Habkost 2010-02-11 09:12:23 EST
sorry for taking too long to reply (again).

This bug seems to be related to virt-manager not using virtio by default when installing RHEL. The change to use virtio for RHEL-5.4+ was addressed at: https://bugzilla.redhat.com/show_bug.cgi?id=547380

Have you seen this issue recently, or there's some time since the last time you tested NFS installs? Do you see this issue if you make sure virtio is used for networking, when installing the guest?
Comment 9 Gary Case 2010-02-11 14:39:23 EST
I've just tried again with the latest 5.4 bits (yum update from RHN) and the problem still occurs. Lots of

<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME OK
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME OK
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME not responding, still trying
<5>nfs: server $SERVERNAME not responding, still trying

with no data appearing on the ctrl-alt-F1 console. I'm installing 5.5 beta now and will let you know how that behaves.
Comment 10 Eduardo Habkost 2010-02-11 14:46:21 EST
Are you using virtio-net on the failing setup? Could you show the 'vish dumpxml' output for the failing guest?
Comment 11 Gary Case 2010-02-11 15:17:47 EST
The RHEL 5.5 beta does not have this problem. I chose the "RHEL5.4 or later" option when setting up the guest (also RHEL5.5 beta) through virt-manager. I don't see any NFS errors on any consoles. Do you want me to probe further into the failing 5.4 installs?
Comment 12 Eduardo Habkost 2010-02-11 15:57:31 EST
If it works on 5.5 beta, it's good news. However, the problem may be still present when non-virtio network device emulation is used. Having virtio working may make the bug have lower priority, but it would be interesting to investigate and fix it for the benefit of users that have guests without virtio support.

Could you show the 'virsh dumpxml' output for the guest on the failing setup?
Comment 13 Eduardo Habkost 2010-02-11 16:02:09 EST
Actually, 'virsh dumpxml' for both cases (working and non-working setup) is interesting, so I can be sure it's failing because of missing virtio support.

Thanks for the help.
Comment 15 Gary Case 2010-02-12 13:54:19 EST
Created attachment 390557 [details]
virsh dumpxml 1 from system RHEL5.4 system exhibiting NFS mount problem

Attaching virsh dumpxml 1 output from RHEL5.4 system experiencing the bug
Comment 16 Gary Case 2010-02-12 15:35:07 EST
Created attachment 390581 [details]
visrh dumpxml 1 from RHEL5.5 beta system that works correctly
Comment 17 Eduardo Habkost 2010-04-09 17:17:06 EDT
The system that works correctly us using virtio, the buggy system is using the default (rtl8139). Using rtl8139 emulation is not recommended unless the guest system doesn't have support for virtio or e1000. Lowering priority and severity.

Note You need to log in before you can comment on or make changes to this bug.