This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 517946 - Some audit rules can freeze all fuse mounts
Some audit rules can freeze all fuse mounts
Status: CLOSED DUPLICATE of bug 493565
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 517000
  Show dependency treegraph
 
Reported: 2009-08-18 02:03 EDT by Christian Lupien
Modified: 2009-08-31 10:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 10:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Lupien 2009-08-18 02:03:05 EDT
Description of problem:
After playing with some seedit utilities I ended up unable to use any fuse file systems. Trying to mount a fuse system would just freeze along the way leaving the mount point in an intermediate state. For example trying to do 
 ls ~/.gvfs
would just hang. Another consequence is that nautilus would freeze when trying to look at my home directory (because of the presence of .gvfs)

After a lot of exploration I found that the culprit was the audit service and in particular a rule that got added by some utilites along the way.

Removing this rule fixed the problem. After this all fuse mount started to work again.

I guess this is probably a kernel bug...

Version-Release number of selected component (if applicable):
Fedora 11
audit-1.7.13-1.fc11
a bunch of kernels:
kernel-2.6.29.4-167.fc11.i586, kernel-2.6.29.6-217.2.7.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. have the the following rule in /etc/audit/audit.rules
-a exit,always -S chroot
2. have the auditd service started
3. Try to mount any fuse filesystem (logging in in gnome will try to mount
     ~/.gvfs)
4. Any access to the mount will block, for example try:
    ls ~/.gvfs
5. Also note that some additional processes are left running (like a mount -i ...)
  
Actual results:
The ls just hangs there and does not return to the shell unless it is killed.

Expected results:
The ls should run normally, display results (maybe nothing) and return to the shell.
Comment 1 Eric Paris 2009-08-31 10:11:27 EDT

*** This bug has been marked as a duplicate of bug 493565 ***

Note You need to log in before you can comment on or make changes to this bug.