Bug 517962 - nouveau not detecting correct resolution
Summary: nouveau not detecting correct resolution
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-18 07:59 UTC by birger
Modified: 2009-10-08 05:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 05:08:13 UTC


Attachments (Terms of Use)
Xorg.0.log (94.35 KB, text/plain)
2009-08-18 08:01 UTC, birger
no flags Details
/var/log/messages (118.46 KB, text/plain)
2009-08-18 08:08 UTC, birger
no flags Details
Xorg.0.log directly attached (167.36 KB, text/plain)
2009-08-18 08:40 UTC, birger
no flags Details
/var/log/messages directly attached (137.76 KB, text/plain)
2009-08-18 08:41 UTC, birger
no flags Details

Description birger 2009-08-18 07:59:12 UTC
Description of problem:
boot system with nvidia card and I get 800x600 resolution

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-2.20090805git712064e.fc12.i686

How reproducible:
always

Steps to Reproduce:
1. boot 
2. check available resolutions in gnome display configurator
3.
  
Actual results:
only 800x600 and 640x480 available

Expected results:
up to 1280x1024 on this monitor

Additional info:
Monitor is Acer AL1917
connected through Black Box ServSwitch jr

I used to get better resolution on this, then some upgrade broke X completely for me more than a month ago.

Comment 1 birger 2009-08-18 08:01:51 UTC
Created attachment 357748 [details]
Xorg.0.log

Comment 2 birger 2009-08-18 08:08:12 UTC
Created attachment 357751 [details]
/var/log/messages

Comment 3 Ben Skeggs 2009-08-18 08:23:57 UTC
If you connect the monitor directly to the graphics card do you still have this issue?  The driver isn't receiving EDID information from the monitor, it's possible your ServSwitch isn't passing that through..

Comment 4 birger 2009-08-18 08:40:05 UTC
I'll attach new files when booting without the switch. It does indeed work. It used to work with the KVM switch. The hardware setup has not changed.

Comment 5 birger 2009-08-18 08:40:45 UTC
Created attachment 357753 [details]
Xorg.0.log directly attached

Comment 6 birger 2009-08-18 08:41:27 UTC
Created attachment 357754 [details]
/var/log/messages directly attached

Comment 7 Ben Skeggs 2009-08-18 09:28:11 UTC
OK, we get EDID information from the monitor in this case.  I highly suspect the KVM to be responsible.

To be more certain, it'd be worth trying with the NVIDIA binary driver to see if it's able to get EDID from the monitor while connected through the KVM.  Unfortunately, until NVIDIA release an update there's no version that'll work with the X server in rawhide.

Comment 8 birger 2009-08-18 09:55:33 UTC
another possibility is of course to remove the nvidia card and insert something else to see if I get EDID data then. I have some kind of ati card somewhere... but their driver may not be ready for the new x server either?

Has something changed in the absence of EDID data? Do drivers behave differently when falling back to some default settings? Should there be some way to override EDID data (/etc/sysconfig/edid ?) in cases where KVM switches interfere?

At home I have a switch that does send out EDID data, but it filters the data and caps the resolution. Since this is a pre-widescreen kvm switch it won't present wide-screen hi-res modes in EDID, but if I tell the OS (windows) to ignore EDID it works just fine. The Sun systems connected to the switch are too old for EDID anyway, so they work just fine as well...

btw: Did you notice the lock issue in the messages file that seems to involve nouveau? It's there in both log files so I assumed it didn't affect my bug, and could be a well known problem.

Comment 9 Andrey 2009-08-20 21:20:04 UTC
What I have here is Sony VAIO FZ11MR (1280*800; Nvidia GeForce 8400M GT). Recently I have installed F11 from LiveCD and resolution (1280*800) has been recognized automatically without problem. After that I have installed proprietary Nvidia drivers from RPMFusion (again, everything worked fine).

Couple of days ago I have upgraded the system fully (yum upgrade). After that proprietary Nvidia driver stopped to work (shows warnings about kernel module during the boot). And in addition resolution dropped to 800*600. There were no other resolutions in Gnome controls except of 800*600 and 640*480.

What I did - I just removed all nvidia related drivers, installed nouveau and replaced /etc/X11/xorg.conf with the default file generated by the 'X -configure' command. Now I have no 3D stuff, but resolution has recovered to 1280*800.

All this has happened after upgrade to 2.6.29.6-217.2.8.fc11.i586. I wonder if my solution could be helpful for the initial author.

Comment 10 Ben Skeggs 2009-09-14 01:46:47 UTC
(In reply to comment #8)
> another possibility is of course to remove the nvidia card and insert something
> else to see if I get EDID data then. I have some kind of ati card somewhere...
> but their driver may not be ready for the new x server either?
Any update here?  If you can't manage to get anything else to retrieve the EDID I'll close this as NOTABUG as the KVM interfering isn't something we can really fix..

> 
> Has something changed in the absence of EDID data? Do drivers behave
> differently when falling back to some default settings? Should there be some
> way to override EDID data (/etc/sysconfig/edid ?) in cases where KVM switches
> interfere?
Something like the binary driver's CustomEDID option could potentially be possible.

> btw: Did you notice the lock issue in the messages file that seems to involve
> nouveau? It's there in both log files so I assumed it didn't affect my bug, and
> could be a well known problem.  
Yeah I noticed them, a few people have reported it but as of yet I haven't seen any of my systems trigger them.

Comment 11 birger 2009-09-15 07:59:38 UTC
I have now tested with another system with ati graphics. Both OpenSolaris and Fedora 11 behave the same. They come up with the low resolution. Windows is the opposite. By default XP comes up with a resolution that the screen cannot display.

I know that Fedora 11 on the nvidia-based pc used to work fine, so something has changed. It could be the KVM switch failing, but that seems a bit odd. It's possible that the screen has been swapped. Since the screen works fine with all OS'es when directly connected I have to assume that the EDID response from the screen somehow confuses the KVM switch. Anyway, it's not a fedora bug. :-)

Some standard way to override edid data would be really nice. Where should I file an RFE? What component is doing the kernel mode probing during boot?

Comment 12 Ben Skeggs 2009-10-08 05:08:13 UTC
Ok, I'll close this bug then since it's not an issue with the driver.  If you wish to, feel free to file a bug against the kernel component requesting CustomEDID as an enhancement.

Thanks!
Ben.


Note You need to log in before you can comment on or make changes to this bug.