Bug 517978 - setkey can't load large configuration files.
Summary: setkey can't load large configuration files.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ipsec-tools
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-18 09:15 UTC by Wade Mealing
Modified: 2018-11-14 20:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-16 18:40:00 UTC


Attachments (Terms of Use)
Bring inline with upstream, to try again on eagain. (763 bytes, patch)
2009-08-18 09:15 UTC, Wade Mealing
no flags Details | Diff

Description Wade Mealing 2009-08-18 09:15:18 UTC
Created attachment 357756 [details]
Bring inline with upstream, to try again on eagain.

Description of problem:

When loading a large configuration file, the kernel can throw back an EAGAIN if busy, this patch attempts to try to continue loading the file.

This seems to be more prevalent on a system that has been up for a while and under load.   

Version-Release number of selected component (if applicable):

ipsec-tools 0.6.5-13


How reproducible:

Possible, but difficult.

Steps to Reproduce:
1. Have system up and running
2. Run setkey -f largeconfigfile
3. Wait.
  
Actual results:

pfkey shows a recv() error, showing "'recv: Resource temporarily unavailable""



Expected results:

pfkey to finish.

Additional info:

I've written a patch to try again, which seems to alleviate the initial problem if the system is too busy to initially take the instruction.

Patch to be attached.

Comment 5 RHEL Product and Program Management 2009-11-06 18:42:55 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 9 Tilman Baumann 2011-01-06 15:18:54 UTC
Has the kernel patch made it into RHEL(6)? How could I verify this myself?

Comment 10 David Mair 2011-10-16 18:40:00 UTC
Closing this out as this case has gone cold and the original reporter has closed the case long ago.


Note You need to log in before you can comment on or make changes to this bug.