This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 518000 - suspend/hibernate from menu not working with PowerDevil disabled after update to KDE 4.3
suspend/hibernate from menu not working with PowerDevil disabled after update...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-18 07:36 EDT by Sebastian Vahl
Modified: 2009-08-24 09:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 08:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 204345 None None None Never

  None (edit)
Description Sebastian Vahl 2009-08-18 07:36:02 EDT
Description of problem:
With KDE 4.3 suspend or hibernate from menu isn't working. The two buttons seems to to nothing. And there is no additional output (/var/log/messages, /var/log/secure, /var/log/pm-suspend, ~/.xsession-errors). 
"solid-powermanagement suspend to_ram" works fine.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.0-5.fc11.x86_64

How reproducible:
ever

Steps to Reproduce:
1. try to suspend or hibernate from menu
  
Actual results:
nothing happens

Expected results:
working suspend/hibernate

Additional info:
This seems not related to #516824 because selinux runs in permissive mode.
Comment 1 Sebastian Vahl 2009-08-18 08:37:01 EDT
Strange. On a new user account all is working fine. So I've copied over my .kde dir and suspend is failing again. The curiuos thing is that it seems to be a compination of a file (or more) in .kde/share/config and my workaround for dual-head in .kde/env/xrandr.sh:
xrandr --output DVI-0 --mode 1152x864 --left-of VGA-0

If I move .kde/share/config or .kde/env/xrandr.sh out of the way and re-login, suspend is working. But with the entries from my normal user account it is failing.
Comment 2 Rex Dieter 2009-08-18 08:44:23 EDT
Interesting, we'd best put this into upstream's hands, bugs.kde.org please.
Comment 3 Sebastian Vahl 2009-08-18 09:25:07 EDT
I'll file a bug upstream later the day.

One thing I could reproduce is that suspend/hibernate from menu aren't working if PowerDevil isn't running. (AFAIR I've disabled it in KDE 4.2.x because the affected machine isn't a laptop).

I'm not sure why the script in .kde/env stopped the suspend. But after starting PowerDevil on my normal user account the suspend is working there, too. And without a running PowerDevil and the removal of the script it is also working. :-? So some other files may be related to this failure (if PowerDevil isn't running).
Comment 4 Rex Dieter 2009-08-18 09:28:54 EDT
I'm fairly certain that kde's suspend feature requires PowerDevil.

should be the same as running command line:

$ solid-powermanagement suspend to_ram
Comment 5 Sebastian Vahl 2009-08-18 10:07:55 EDT
That's the point: 
+ "solid-powermanagement suspend to_ram" is working all the time. 
+ With PowerDevil enabled suspend is working all the time. 
+ With PowerDevil disabled and some config files from my old .kde/share/config and without .kde/env/xrandr.sh being present suspend is working
- With PowerDevil disabled and some config files from my old .kde/share/config and with .kde/env/xrandr.sh being present suspend isn't working
- With PowerDevil disabled on a clean user account suspend isn't working

But I don't know which config file also trigger the suspend.
Comment 6 Sebastian Vahl 2009-08-18 18:03:57 EDT
I've filed it upstream: https://bugs.kde.org/show_bug.cgi?id=204345
Comment 7 Kevin Kofler 2009-08-24 08:26:34 EDT
While I agree we should get this fixed, I don't think we should block the KDE 4.3.0 update over this (as it isn't likely to affect all that many users, given that it appears to only happen with PowerDevil disabled) => removing from kde-4.3.0 tracker and closing as UPSTREAM.
Comment 8 Sebastian Vahl 2009-08-24 09:00:01 EDT
Agreed.

Note You need to log in before you can comment on or make changes to this bug.