Bug 518026 - Cancelled job doesn't kill backend
Cancelled job doesn't kill backend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 516998 fitandfinish
  Show dependency treegraph
 
Reported: 2009-08-18 10:20 EDT by Tim Waugh
Modified: 2009-08-24 07:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.4-0.rc1.16.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 07:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3292 None None None Never

  None (edit)
Description Tim Waugh 2009-08-18 10:20:47 EDT
Description of problem:
When a job is cancelled the backend is still running.

Version-Release number of selected component (if applicable):
cups-1.4-0.rc1.15.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Configure a USB printer (using the usb backend)
2.Print a test page, with no paper loaded.
3.Cancel the job.
4.lpinfo -v (as root)
  
Actual results:
USB device not discovered.

Expected results:
USB device is still discovered.

Additional info:
The reason is that the usb backend is holding the device busy.

Note You need to log in before you can comment on or make changes to this bug.