Bug 51806 - /usr/sbin/sensors-detect corrupts firmware
/usr/sbin/sensors-detect corrupts firmware
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: lm_sensors (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-15 09:16 EDT by Michal Roszkowski
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-15 09:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Roszkowski 2001-08-15 09:16:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010706

Description of problem:
after running /usr/sbin/sensors-detect on an IBM Thinkpad 570, the firmware
is corrupted. Machine cannot boot, but hangs with:
0188: Invalid RFID Serialization Area

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run /usr/sbin/sensors-detect
2. i2c-piix4 and eeprom modules are loaded by the sensors-detect script
3. reboot... firmware is dead!
	

Actual Results:  cannot boot system,
seems like a motherboard replacement is the only solution!

Additional info:
Comment 1 Phil Knirsch 2001-08-16 10:41:11 EDT
This is a know problem on IBM Thinkpads. IBM knows about this problem.

The problem is that we can't really do anything about it except offer a warning
not to run this package on IBM Thinkpads as there is no way i know of to
determine if lm_sonsors is being run an a Thinkpad.

The http://www.linux-thinkpad.org/ website also warns about this problem.

I know this doesn't really help you a lot, but i'd suggest you should complain
to IBM for not fixing this really hardware or BIOS related problem.

At least your IBM dealer should replace the board as mentioned on the above website.
Sorry for the inconvenience.

Read ya, Phil
Comment 2 jon 2002-05-13 10:30:56 EDT
Please note that with Red Hat 7.3 I experienced a similar problem on my Thinkpad
X21. (I got an 0189 Invalid RFID error in the BIOS, FWIW.) However, I don't
recall ever having selected the lm_sensors package, and I certainly didn't
manually run any command related to the package. Does Red Hat 7.3 automatically
enable / try this if the package is installed? I'd take a look myself, but my
laptop is on its way back to IBM right now...

Note You need to log in before you can comment on or make changes to this bug.