Bug 51807 - Create a tag with a shared cookie
Summary: Create a tag with a shared cookie
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-15 13:19 UTC by Peter Bowen
Modified: 2007-03-27 03:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-15 13:19:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bowen 2001-08-15 13:19:52 UTC
It would be nice if there was a "shared cookie" tag for binary RPMS that
would link a binary RPM to its source RPM.  It would be, similar to the
COOKIE tag, but it would be common among the source RPM and all the binary
RPMs built from it.

This would help track RPMs as it currently isn't possible to tell if
foo-1.0-1.alpha.rpm and foo-1.0-1.i386.rpm actually came from the same SRPM
or if someone just happened to give them the same version number.

Comment 1 Jeff Johnson 2001-08-15 13:26:55 UTC
What's missing is the glue that points the src.rpm to a set of
binary rpm's. This cannot be easily done because
	a) a src.rpm is implicitly noarch, can be produced on any
	machines, even if there are %ifarch subpackages.
	b) src rpm's can be built w/o building packages.
	c) bianary rpm's can be built w/o src rpm's.
cookies have all the above problems.


Note You need to log in before you can comment on or make changes to this bug.