Bug 518074 - Anaconda cannot configure static IP networks ( with VMWare )
Summary: Anaconda cannot configure static IP networks ( with VMWare )
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: i386
OS: Linux
low
urgent
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-18 18:46 UTC by Charlweed Hymerfan
Modified: 2009-09-29 19:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 19:42:12 UTC
Type: ---


Attachments (Terms of Use)
Anaconda log, Obtailed with loglevel=debug as kernel parameter. (42.88 KB, text/plain)
2009-08-20 19:14 UTC, Charlweed Hymerfan
no flags Details
Anaconda syslog, Obtained with loglevel=debug as kernel parameter. (4.34 KB, text/plain)
2009-08-20 19:14 UTC, Charlweed Hymerfan
no flags Details
Generated Kickstart file (1.28 KB, text/plain)
2009-08-20 19:19 UTC, Charlweed Hymerfan
no flags Details
/var/log/anaconda.log (36.68 KB, text/plain)
2009-08-25 15:37 UTC, Charlweed Hymerfan
no flags Details
/var/log/anaconda.syslog (68.00 KB, text/plain)
2009-08-25 15:37 UTC, Charlweed Hymerfan
no flags Details
/var/log/anaconda.xlog (22.11 KB, text/plain)
2009-08-25 15:38 UTC, Charlweed Hymerfan
no flags Details

Description Charlweed Hymerfan 2009-08-18 18:46:06 UTC
Description of problem:

Ethernet network does not configure with given IP, netmask, gateway, and nameservers. The Network CAN be correctly configured after installation with full OS.

I have tried configuring with kernel parameters, a floppy kickstart file, and from the Anaconda GUI. If static parameters are supplied, then none of them set up Ethernet. The ethernet indicator LEDs indicate there is no network activity.


Version-Release number of selected component (if applicable):

Anaconda 11.5.0.59

How reproducible:
Every time.

Steps to Reproduce:
1. Boot from installation media
2. Specify IP, netmask, gateway, and nameservers 
3. Attempt to continue installation.
  
Actual results:
Network failed to configure

Expected results:
Network connects

Additional info:
Tested system is a VMWare Workstation 6.5, with bridged networking.

Comment 1 David Cantrell 2009-08-18 20:15:59 UTC
You can run the installation with the following boot parameter in addition to whatever other boot parameters you use to start the installer:

    loglevel=debug

Run the installer as you have that led to this bug.  After installation, collect the /root/install.log and /root/install.log.syslog files and attach them to this bug report.

Comment 2 Charlweed Hymerfan 2009-08-20 19:14:01 UTC
Created attachment 358152 [details]
Anaconda log,  Obtailed with loglevel=debug as kernel parameter.

Not as verbose as I would expect....

Comment 3 Charlweed Hymerfan 2009-08-20 19:14:53 UTC
Created attachment 358154 [details]
Anaconda syslog,  Obtained with loglevel=debug as kernel parameter.

Comment 4 Charlweed Hymerfan 2009-08-20 19:19:25 UTC
Created attachment 358157 [details]
Generated Kickstart file

All three were generated from the same install attempt. After install, the bridged network did work, but not during install.

Comment 5 David Cantrell 2009-08-25 02:58:16 UTC
I'm sorry, I meant to ask for the /var/log/anaconda* files off the installed system.  Still perform the installation using loglevel=debug

My mistake, sorry about that.

Comment 6 Charlweed Hymerfan 2009-08-25 15:37:06 UTC
Created attachment 358590 [details]
/var/log/anaconda.log

The files were still there.

Comment 7 Charlweed Hymerfan 2009-08-25 15:37:46 UTC
Created attachment 358591 [details]
/var/log/anaconda.syslog

Comment 8 Charlweed Hymerfan 2009-08-25 15:38:24 UTC
Created attachment 358592 [details]
/var/log/anaconda.xlog

Comment 9 David Cantrell 2009-09-04 20:02:19 UTC
I don't see anything obvious in the logs.  Since this is VMware, the only thing I can do is ask you to try the latest development snapshot of Fedora and see if it fixes the problem.  If it does, then the problem won't be present in F-12.  I don't have VMware and cannot easily debug problems with it.

The latest development trees can be found here:
http://download.fedora.redhat.com/pub/fedora/linux/development/$ARCH/os/

Where $ARCH would be i386 or x86_64.  The /os subdirectory will have an images subdirectory containing boot images.  The boot.iso file would probably be easiest for you in VMware.

NOTE: If there is not an 'images' subdirectory, it means the development tree build did not complete from the previous night.  This happens sometimes, so you just have to check the next day and see if one is there.

Comment 10 David Cantrell 2009-09-29 19:42:12 UTC
Since this is vmware, there's not really anything else I can do.


Note You need to log in before you can comment on or make changes to this bug.