Bug 518093 - [LTC 5.5 FEAT] Async notification of watchdog events [202013]
Summary: [LTC 5.5 FEAT] Async notification of watchdog events [202013]
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm
Version: 5.5
Hardware: All
OS: All
high
high
Target Milestone: beta
: 5.5
Assignee: Eduardo Habkost
QA Contact: Lawrence Lim
URL:
Whiteboard:
Depends On:
Blocks: 481160 518095
TreeView+ depends on / blocked
 
Reported: 2009-08-18 20:50 UTC by IBM Bug Proxy
Modified: 2014-03-26 01:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 13:28:11 UTC


Attachments (Terms of Use)
qemu watchdog emulation for kvm-83 (31.51 KB, patch)
2009-10-02 23:00 UTC, IBM Bug Proxy
no flags Details | Diff
Patch rebased to latest RHEL-5.5 KVM tree. (34.10 KB, patch)
2009-10-06 20:09 UTC, Eduardo Habkost
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 55533 None None None Never

Description IBM Bug Proxy 2009-08-18 20:50:25 UTC
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[202013]
a. Name of Feature:	Add async qemu machine protocol (qmp) to qemu
b. Feature Description
Extend qemu to include a machine protocol for the monitor interface

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64

Arch Specificity: Both
Affects Kernel Modules: Yes
Delivery Mechanism: Backport
Category:	Xen
Request Type:	Driver - New - Open Source
d. Upstream Acceptance:	Pending
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	qemu 0.12+

3. Business Case
By switching to a machine readable protocol we increase the robustness of the interface that is used
to control qemu

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com

Technical contact(s):
Ryan Harper, raharper@us.ibm.com

IBM Manager:
Warren Grunbok II, grunbok@us.ibm.com

Comment 1 Eduardo Habkost 2009-08-19 14:08:41 UTC
We can't include the current QMP work on RHEL-5.5. It is intrusive code, and still in development upstream.

We already have a machine-friendly and stable interface to control qemu-kvm on RHEL5, that is libvirt.

If the request is for the asynchronous notification feature only, we have an existing asynchronous notification system (bug #501693).

Comment 2 IBM Bug Proxy 2009-08-19 21:01:12 UTC
------- Comment From hollisb@us.ibm.com 2009-08-19 16:57 EDT-------
OK, this request should really be about changing the qemu watchdog to use the asynchronous message framework referenced in bug #501693 then.

Comment 3 Eduardo Habkost 2009-08-21 18:24:40 UTC
Should we close this as duplicate of #518703, or do you plan to use this bug to track the async watchdog notification feature?

Comment 4 IBM Bug Proxy 2009-08-22 00:20:34 UTC
------- Comment From hollisb@us.ibm.com 2009-08-21 20:14 EDT-------
We should track qemu generation of async watchdog events here.

Also, this bug is for version 5.5, while bug #518703 is for 6.0.

Comment 5 IBM Bug Proxy 2009-10-02 23:00:35 UTC
Created attachment 363535 [details]
qemu watchdog emulation for kvm-83


------- Comment on attachment From hollisb@us.ibm.com 2009-10-02 18:59 EDT-------


This is a backport of the latest upstream qemu watchdog emulation. In addition, it adds support for RHEL5's asynchronous monitor messages with the new "notify" watchdog action.

This was tested with a RHEL5.3 guest using the i6300esb module, with "poweroff" and "notify" actions.

Comment 7 Eduardo Habkost 2009-10-06 20:11:03 UTC
Comment on attachment 363889 [details]
Patch rebased to latest RHEL-5.5 KVM tree.

Attached patch rebased to latest RHEL-5.5 KVM tree and with some space/tab mixups fixed.

Comment 9 IBM Bug Proxy 2009-10-06 21:22:17 UTC
------- Comment From hollisb@us.ibm.com 2009-10-06 17:18 EDT-------
We don't need this feature in 5.5, since libvirt doesn't consume any of the async events.

Comment 10 Eduardo Habkost 2009-10-06 21:36:44 UTC
(In reply to comment #9)
> ------- Comment From hollisb@us.ibm.com 2009-10-06 17:18 EDT-------
> We don't need this feature in 5.5, since libvirt doesn't consume any of the
> async events.  

Should I close this as WONTFIX (or NOTABUG), then?

Comment 11 IBM Bug Proxy 2009-10-07 11:41:00 UTC
------- Comment From sglass@us.ibm.com 2009-10-07 07:31 EDT-------
Please close as WONTFIX.  Thanks

Comment 12 Dor Laor 2009-10-08 07:44:46 UTC
(In reply to comment #11)
> ------- Comment From sglass@us.ibm.com 2009-10-07 07:31 EDT-------
> Please close as WONTFIX.  Thanks  

Do you still interested in the watchdog device for rhel5.5 or just drop the async messages for it?
( Bug 513829 -  FEAT: watch dog device)

Comment 13 IBM Bug Proxy 2009-10-08 22:10:53 UTC
------- Comment From hollisb@us.ibm.com 2009-10-08 18:08 EDT-------
Please close that one too, thanks.


Note You need to log in before you can comment on or make changes to this bug.