Bug 518097 - [LTC 5.5 FEAT] Switch qemu to use gpxe option rom for netboot [202015]
Summary: [LTC 5.5 FEAT] Switch qemu to use gpxe option rom for netboot [202015]
Keywords:
Status: CLOSED DUPLICATE of bug 546019
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm
Version: 5.5
Hardware: All
OS: All
high
high
Target Milestone: beta
: 5.5
Assignee: Glauber Costa
QA Contact: Lawrence Lim
URL:
Whiteboard:
Depends On: 512045 546019
Blocks: 556823 557291 481160 533941 533951
TreeView+ depends on / blocked
 
Reported: 2009-08-18 21:10 UTC by IBM Bug Proxy
Modified: 2014-03-26 01:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-18 12:01:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 55535 None None None Never

Description IBM Bug Proxy 2009-08-18 21:10:23 UTC
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[202015]
a. Name of Feature:	Switch qemu to use gpxe option rom for netboot
b. Feature Description
Switch qemu over to using gpxe option rom for network booting

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64

Arch Specificity: Both
Affects Kernel Modules: Yes
Delivery Mechanism: Backport
Category:	Xen
Request Type:	Driver - Feature from Upstream
d. Upstream Acceptance:	In Progress
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	gPXE 0.97 or newer, gemu-0.12 or newer

3. Business Case
IBM has a number of products that require a richer netweork booting environment.  Tivoli Provision
manager has a program that makes extensive use of PXE UNDI mode which has much better support in
gPXE than the current etherboot module.  Additionally, gPXE also includes iSCSI booting support
which is a key diskless technology that IBM employs in bare-metal scenarios.  Adding gPXE allows
virtualization to fit more seamlessly into existing customer environments.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Ryan Arnold, ryanarn@us.ibm.com

IBM Manager:
Warren Grunbok II, grunbok@us.ibm.com

Comment 1 Eduardo Habkost 2009-08-19 14:20:28 UTC
Moving to gPXE was also requested on bug #488879, but for RHEL-6.

Comment 3 IBM Bug Proxy 2009-09-18 17:40:47 UTC
------- Comment From ryanh@us.ibm.com 2009-09-18 13:34 EDT-------
F11 has gPXE packaged:
https://bugzilla.redhat.com/show_bug.cgi?id=492181

F12 is planning the switch.
http://fedoraproject.org/wiki/Features/VirtgPXE

Work is already done upstream, just need to pull in for 5.5

Comment 5 John Jarvis 2009-10-26 13:03:15 UTC
IBM is signed up to test and provide feedback.

Comment 7 John Jarvis 2009-10-29 18:30:30 UTC
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.

Comment 9 Eduardo Habkost 2010-01-18 12:01:27 UTC

*** This bug has been marked as a duplicate of bug 546019 ***


Note You need to log in before you can comment on or make changes to this bug.