Bug 518110 - anaconda crash during installation on Presario 2267AP notebook
Summary: anaconda crash during installation on Presario 2267AP notebook
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
Whiteboard: anaconda_trace_hash:af11585b415e12721...
Depends On:
TreeView+ depends on / blocked
Reported: 2009-08-18 22:03 UTC by Ruediger Landmann
Modified: 2014-01-21 23:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2010-12-05 06:35:26 UTC
Type: ---

Attachments (Terms of Use)
Attached traceback automatically from anaconda. (191.77 KB, text/plain)
2009-08-18 22:03 UTC, Ruediger Landmann
no flags Details

Description Ruediger Landmann 2009-08-18 22:03:52 UTC
The following was filed automatically by anaconda:
anaconda exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 161, in __getattr__
    raise KeyError, str(e)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 179, in _loadFiles
    if self._loadedfiles:
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 243, in returnFileTypes
  File "/usr/lib/anaconda/yuminstall.py", line 728, in getDownloadPkgs
    for filetype in po.returnFileTypes():
  File "/usr/lib/anaconda/yuminstall.py", line 1330, in doPostSelection
    (self.dlpkgs, self.totalSize, self.totalFiles)  = self.ayum.getDownloadPkgs()
  File "/usr/lib/anaconda/backend.py", line 279, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
KeyError: 'no such column: _loadedfiles'

Comment 1 Ruediger Landmann 2009-08-18 22:03:59 UTC
Created attachment 357857 [details]
Attached traceback automatically from anaconda.

Comment 2 James Antill 2009-08-24 19:38:16 UTC
So I tried pasting the getDownloadPkgs() into yum, and outputting it in reportDownloadSize(). Which is (I assume) roughly where you are doing it in anaconda. Everything works fine (tried: install, upgrade, downgrade, reinstall).

Also, looking at the code, I can't see how this can possibly happen as _loadedfiles is always there.

Some help from anaconda peeps. would be nice.

Comment 3 Bug Zapper 2009-11-16 11:32:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:

Comment 4 Bug Zapper 2010-11-04 10:27:36 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Comment 5 Bug Zapper 2010-12-05 06:35:26 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.