Bug 518121 - Segmentation Fault with QGIS 1.0.2
Summary: Segmentation Fault with QGIS 1.0.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qgis
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Douglas E. Warner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-19 01:10 UTC by TDRogers
Modified: 2009-11-04 12:33 UTC (History)
5 users (show)

Fixed In Version: 1.0.2-1.fc11.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-04 12:33:11 UTC


Attachments (Terms of Use)
Stacktrace (22.29 KB, text/plain)
2009-08-27 22:20 UTC, Russell Harrison
no flags Details
Full output from yum (17.11 KB, text/plain)
2009-10-23 07:00 UTC, Zirneklitis
no flags Details

Description TDRogers 2009-08-19 01:10:17 UTC
Description of problem:

I am running Fedora 11.  I had QGIS 1.0.1 (qgis-1.0.1-2.fc11.i586.rpm), along with QGIS-GRASS and QGIS-python packages straight off the Fedora repo.

I ran yum today, and it updated QGIS and others to 1.0.2 (qgis-1.0.2-1.fc11.i586.rpm).  When I run it from the menu, the splash screen pops up, disappears, and nothing more happens.  When I run it from the command line, the same thing happens, and it print "Segmentation fault" in the konsole window.

I downgraded back to 1.0.1 so I can get my work done.


Version-Release number of selected component (if applicable):
1.0.2


How reproducible: 
It happened the three times I tried it.


Steps to Reproduce:
1. Install QGIS, QGIS-GRASS, and QGIS-python 1.0.2
2. Run QGIS

  
Actual results:
Segmentation fault and program crashes.


Expected results:
Program should run.


Additional info:

Comment 1 Douglas E. Warner 2009-08-19 01:29:58 UTC
Can you confirm that it's not bug#498111?

Comment 2 TDRogers 2009-08-20 01:37:11 UTC
No, I cannot.  I can't even complete Step 1.

Whatever the problem is, it's in the QGIS-python package...  Removing that one let's QGIS and the GRASS plugin work.

Comment 3 Russell Harrison 2009-08-27 19:13:47 UTC
(In reply to comment #1)
> Can you confirm that it's not bug#498111?  

I can confirm that it isn't the same bug.  Removing the qgis-python package allows qgis to start provided I have already done the qtconfig-qt4 theme workaround for bug 498111.

Reinstalling qgis-python results in the segfault from this bug.

Comment 4 Russell Harrison 2009-08-27 22:20:24 UTC
Created attachment 358975 [details]
Stacktrace

Comment 5 Zirneklitis 2009-09-14 01:48:46 UTC
I can confirm Comment #3. (on 32-bit Fedora 11) I have installed "Python integration and plugins for qgis". Sometimes (randomly) QGIS starts with the following message:

----------------------------
Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in 
RuntimeError: the sip module implements API v5.0 but the rVsV module requires API v3.8

Python version:
2.6 (r26:66714, Jun  8 2009, 16:07:26) 
[GCC 4.4.0 20090506 (Red Hat 4.4.0-4)]

Python path:
['/usr/share/qgis/python', '/home/karlo/.qgis//python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python26.zip', '/usr/lib/python2.6', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/lib/python2.6/site-packages', '/usr/lib/python2.6/site-packages/Numeric', '/usr/lib/python2.6/site-packages/PIL', '/usr/lib/python2.6/site-packages/gst-0.10', '/usr/lib/python2.6/site-packages/gtk-2.0', '/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode']
--------------------

Otherwise "Segmentation fault"  and QGIS is not lunched.

Comment 6 Zirneklitis 2009-09-14 09:12:12 UTC
If 64-bit Fedora 11 is used the only response for "Python
integration and plugins for qgis" is "Segmentation fault".

Comment 7 Russell Harrison 2009-10-20 15:16:46 UTC
Is there any further information we could help collect to aid with determining the solution for this issue?

Comment 8 Zirneklitis 2009-10-21 02:10:29 UTC
Just guessing - wrong Python version. MS Windows based QGIS packages relay on Python 2.5. Fedora 11 has been packed with Python 2.6.

Comment 9 Zirneklitis 2009-10-21 03:11:18 UTC
I was wrong :(  (Comment #8) - Ubuntu 9.04 + Qgis 1.0.2 + Python 2.6.2 works as expected.

May be I was not wrong as a lot of bugs has been fixed since Python 2.6:

http://www.python.org/download/releases/2.6.1/NEWS.txt
http://www.python.org/download/releases/2.6.2/NEWS.txt
http://www.python.org/download/releases/2.6.3/NEWS.txt

Several of the fixed bugs has a key-word 'segfault'

Comment 10 Russell Harrison 2009-10-22 04:20:19 UTC
Looks like the packages simply need to be rebuilt.  I rebuilt the src.rpm package for qgis without any changes and installed the resulting rpms.  Looks like things are working including the python plugins.

Comment 11 Alex Lancaster 2009-10-23 03:17:56 UTC
(In reply to comment #10)
> Looks like the packages simply need to be rebuilt.  I rebuilt the src.rpm
> package for qgis without any changes and installed the resulting rpms.  Looks
> like things are working including the python plugins.  

I just did a scratch build on koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1764052

installed the resulting packages, and they appear to fix the segfault.  If nobody objects, I'll commit the change to CVS and push out an update to updates-testing.

Comment 12 Fedora Update System 2009-10-23 03:39:12 UTC
qgis-1.0.2-1.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qgis-1.0.2-1.fc11.1

Comment 13 Zirneklitis 2009-10-23 05:30:06 UTC
I have downloaded qgis-1.0.2-1.fc11.1.x86_64.rpm from http://koji.fedoraproject.org/koji/buildinfo?buildID=137913.

This package has wrong dependencies. The command
yum localinstall qgis-1.0.2-1.fc11.1.x86_64.rpm
ends up with 44 dependencies. All of them was for Fedora 11 i586 not for x64.

Comment 14 Alex Lancaster 2009-10-23 06:14:25 UTC
(In reply to comment #13)
> I have downloaded qgis-1.0.2-1.fc11.1.x86_64.rpm from
> http://koji.fedoraproject.org/koji/buildinfo?buildID=137913.
> 
> This package has wrong dependencies. The command
> yum localinstall qgis-1.0.2-1.fc11.1.x86_64.rpm
> ends up with 44 dependencies. All of them was for Fedora 11 i586 not for x64.  

Can you post your full output from yum?

Comment 15 Alex Lancaster 2009-10-23 06:19:16 UTC
I removed qgis and qgis-python and downloaded the built RPMs from that page it successfully resolves deps on x86_64 without any additional i586 deps:

$ sudo yum localinstall qgis-python-1.0.2-1.fc11.1.x86_64.rpm qgis-1.0.2-1.fc11.1.x86_64.rpm 
Loaded plugins: allowdowngrade, changelog, dellsysidplugin2, downloadonly,
              : fastestmirror, presto, priorities, protectbase, refresh-
              : packagekit, tsflags, versionlock
Setting up Local Package Process
Examining qgis-python-1.0.2-1.fc11.1.x86_64.rpm: qgis-python-1.0.2-1.fc11.1.x86_64
Marking qgis-python-1.0.2-1.fc11.1.x86_64.rpm to be installed
Loading mirror speeds from cached hostfile
<snip>
 packages excluded due to repository protections
Examining qgis-1.0.2-1.fc11.1.x86_64.rpm: qgis-1.0.2-1.fc11.1.x86_64
Marking qgis-1.0.2-1.fc11.1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package qgis.x86_64 0:1.0.2-1.fc11.1 set to be updated
---> Package qgis-python.x86_64 0:1.0.2-1.fc11.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================
 Package     Arch   Version           Repository                          Size
===============================================================================
Installing:
 qgis        x86_64 1.0.2-1.fc11.1    /qgis-1.0.2-1.fc11.1.x86_64         12 M
 qgis-python x86_64 1.0.2-1.fc11.1    /qgis-python-1.0.2-1.fc11.1.x86_64 1.7 M

Transaction Summary
===============================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total size: 14 M
Is this ok [y/N]:

Comment 16 Zirneklitis 2009-10-23 06:58:29 UTC
(In reply to comment #14)
I shall add the output as a text file

Comment 17 Zirneklitis 2009-10-23 07:00:05 UTC
Created attachment 365818 [details]
Full output from yum

Comment 18 Alex Lancaster 2009-10-23 07:09:53 UTC
This part suggests that you already have both i586 and x86_64 versions of qgis already installed:

---> Package qgis.x86_64 0:1.0.2-1.fc11.1 set to be updated
--> Running transaction check
---> Package qgis.i586 0:1.0.2-1.fc11 set to be updated

If you run before the install:

rpm -q qgis 

what do you get?

Comment 19 Zirneklitis 2009-10-23 07:22:11 UTC
[root@tatooine QGIS]# rpm -q qgis
qgis-1.0.2-1.fc11.x86_64

Comment 20 Alex Lancaster 2009-10-23 07:29:30 UTC
I tried reinstalling the old qgis and then locally-installing the RPM as you did, but I can't seem to reproduce this.  I suspect that some of the old qgis packages are causing some problems, can you try "yum remove"ing all of your qgis-related packages and installing the new ones afresh?

Hopefully we'll get more feedback from other users when this update gets pushed to updates-testing.

Comment 21 Alex Lancaster 2009-10-23 07:43:13 UTC
OK, I can duplicate the error now.  Let's say I have the following installed:

$ rpm -qa|grep qgis
qgis-1.0.2-1.fc11.x86_64
qgis-theme-classic-1.0.2-1.fc11.x86_64
qgis-python-1.0.2-1.fc11.x86_64
qgis-theme-nkids-1.0.2-1.fc11.x86_64

Then I attempt to only upgrade only qgis and qgis-python RPMs:

$ sudo yum localinstall qgis-python-1.0.2-1.fc11.1.x86_64.rpm qgis-1.0.2-1.fc11.1.x86_64.rpm 
Loaded plugins: allowdowngrade, changelog, dellsysidplugin2, downloadonly,
              : fastestmirror, presto, priorities, protectbase, refresh-
              : packagekit, tsflags, versionlock
Setting up Local Package Process
Examining qgis-python-1.0.2-1.fc11.1.x86_64.rpm: qgis-python-1.0.2-1.fc11.1.x86_64
Marking qgis-python-1.0.2-1.fc11.1.x86_64.rpm as an update to qgis-python-1.0.2-1.fc11.x86_64
0 packages excluded due to repository protections
Examining qgis-1.0.2-1.fc11.1.x86_64.rpm: qgis-1.0.2-1.fc11.1.x86_64
Marking qgis-1.0.2-1.fc11.1.x86_64.rpm as an update to qgis-1.0.2-1.fc11.x86_64
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: qgis = 1.0.2-1.fc11 for package: qgis-theme-classic-1.0.2-1.fc11.x86_64
--> Processing Dependency: qgis = 1.0.2-1.fc11 for package: qgis-theme-nkids-1.0.2-1.fc11.x86_64
---> Package qgis.x86_64 0:1.0.2-1.fc11.1 set to be updated
---> Package qgis-python.x86_64 0:1.0.2-1.fc11.1 set to be updated
--> Running transaction check
---> Package qgis.i586 0:1.0.2-1.fc11 set to be updated
--> Processing Dependency: libgsl.so.0 for package: qgis-1.0.2-1.fc11.i586
--> Processing Dependency: libproj.so.0 for package: qgis-1.0.2-1.fc11.i586
--> Processing Dependency: libgslcblas.so.0 for package: qgis-1.0.2-1.fc11.i586
--> Processing Dependency: libgeos_c.so.1 for package: qgis-1.0.2-1.fc11.i586
--> Processing Dependency: libpq.so.5 for package: qgis-1.0.2-1.fc11.i586
--> Processing Dependency: libgdal.so.1 for package: qgis-1.0.2-1.fc11.i586
--> Running transaction check
---> Package gdal.i586 0:1.6.0-8.fc11 set to be updated
--> Processing Dependency: libgrass_gmath.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_dig2.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_rtree.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgeotiff.so.1.2 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libodbc.so.2 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libhdf5.so.6 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_gproj.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_gis.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_datetime.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_I.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libodbcinst.so.2 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libmysqlclient.so.16 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_dgl.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_vect.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libnetcdf.so.4 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: librx.so.0 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libxerces-c.so.28 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgif.so.4 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libdapclient.so.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libdap.so.9 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libogdi.so.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_dbmiclient.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libdapserver.so.6 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libgrass_linkm.so.6.3 for package: gdal-1.6.0-8.fc11.i586
--> Processing Dependency: libcfitsio.so.0 for package: gdal-1.6.0-8.fc11.i586

<snipped output> 

However if I supply all the packages to be update, it proceeds normally:

$ sudo yum localinstall qgis-1.0.2-1.fc11.1.x86_64.rpm qgis-theme-classic-1.0.2-1.fc11.1.x86_64.rpm qgis-python-1.0.2-1.fc11.1.x86_64.rpm qgis-theme-nkids-1.0.2-1.fc11.1.x86_64.rpm 
Loaded plugins: allowdowngrade, changelog, dellsysidplugin2, downloadonly,
              : fastestmirror, presto, priorities, protectbase, refresh-
              : packagekit, tsflags, versionlock
Setting up Local Package Process
Examining qgis-1.0.2-1.fc11.1.x86_64.rpm: qgis-1.0.2-1.fc11.1.x86_64
Marking qgis-1.0.2-1.fc11.1.x86_64.rpm as an update to qgis-1.0.2-1.fc11.x86_64
0 packages excluded due to repository protections
Examining qgis-theme-classic-1.0.2-1.fc11.1.x86_64.rpm: qgis-theme-classic-1.0.2-1.fc11.1.x86_64
Marking qgis-theme-classic-1.0.2-1.fc11.1.x86_64.rpm as an update to qgis-theme-classic-1.0.2-1.fc11.x86_64
Examining qgis-python-1.0.2-1.fc11.1.x86_64.rpm: qgis-python-1.0.2-1.fc11.1.x86_64
Marking qgis-python-1.0.2-1.fc11.1.x86_64.rpm as an update to qgis-python-1.0.2-1.fc11.x86_64
Examining qgis-theme-nkids-1.0.2-1.fc11.1.x86_64.rpm: qgis-theme-nkids-1.0.2-1.fc11.1.x86_64
Marking qgis-theme-nkids-1.0.2-1.fc11.1.x86_64.rpm as an update to qgis-theme-nkids-1.0.2-1.fc11.x86_64
Resolving Dependencies
--> Running transaction check
---> Package qgis.x86_64 0:1.0.2-1.fc11.1 set to be updated
---> Package qgis-python.x86_64 0:1.0.2-1.fc11.1 set to be updated
---> Package qgis-theme-classic.x86_64 0:1.0.2-1.fc11.1 set to be updated
---> Package qgis-theme-nkids.x86_64 0:1.0.2-1.fc11.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================
 Package
      Arch   Version           Repository                                 Size
===============================================================================
Updating:
 qgis x86_64 1.0.2-1.fc11.1    /qgis-1.0.2-1.fc11.1.x86_64                12 M
 qgis-python
      x86_64 1.0.2-1.fc11.1    /qgis-python-1.0.2-1.fc11.1.x86_64        1.7 M
 qgis-theme-classic
      x86_64 1.0.2-1.fc11.1    /qgis-theme-classic-1.0.2-1.fc11.1.x86_64 284 k
 qgis-theme-nkids
      x86_64 1.0.2-1.fc11.1    /qgis-theme-nkids-1.0.2-1.fc11.1.x86_64    67 k

Transaction Summary
===============================================================================
Install       0 Package(s)
Upgrade       4 Package(s)

Total size: 14 M
Is this ok [y/N]: 

It seems if you don't give all the names of the packages that are to be updated in the localinstall then you can get errors like this probably due to the way yum handles multilib.  In any case, once the packages go to updates-testing and you do a proper "yum update" it should update all the packages correctly.

Comment 22 Zirneklitis 2009-10-23 07:53:47 UTC
Command
yum erase qgis 
resolves the issue for me.

Only development package will install all dependencies for x64 and i586 as well:
yum  localinstall qgis-devel-1.0.2-1.fc11.1.x86_64.rpm
But that's why it's a development package.

Now the python plug-ins work!

Comment 23 Fedora Update System 2009-10-27 06:39:00 UTC
qgis-1.0.2-1.fc11.1 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qgis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10744

Comment 24 Alex Lancaster 2009-10-27 23:32:28 UTC
(In reply to comment #22)

In reply to your bodhi error, please post the exact commands and the full output.

Did you clean the metadata before you tried the upgrade?

yum clean metadata

to make sure you have the most recent package lists.

Comment 25 Zirneklitis 2009-10-28 02:52:02 UTC
Sorry, what is 'bodhi error'?

Comment 26 Alex Lancaster 2009-10-28 04:51:55 UTC
(In reply to comment #25)
> Sorry, what is 'bodhi error'?  

The error report you made on the bodhi update:

http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10744

Bodhi is the name for the Fedora Update System:

http://fedoraproject.org/wiki/Bodhi_Guide

Comment 27 Fedora Update System 2009-11-04 12:33:05 UTC
qgis-1.0.2-1.fc11.1 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.