Bug 518178 - Build Audacious plugin?
Summary: Build Audacious plugin?
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms-crossfade
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-19 10:47 UTC by Michael Schwendt
Modified: 2009-12-09 17:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-09 16:01:48 UTC


Attachments (Terms of Use)
spec changes (4.28 KB, text/plain)
2009-09-02 11:28 UTC, Michael Schwendt
no flags Details

Description Michael Schwendt 2009-08-19 10:47:04 UTC
On the German Fedora message boards it has been pointed out that xmms-crossfade can be built also for Audacious instead of just XMMS. This can be done with version 0.3.11 and newer:

  --enable-player=audacious

With 0.3.14 it actually builds for Fedora 11 (Audacious 1.5.x). It could be put into a sub-package "audacious-plugins-crossfade". Is there interest in doing that?

[...]

Note, however:

1) One could not separate %build and %install cleanly, since the results of the second run of %configure with different arguments would override the results of the first run. To split %build and %install cleanly, a work-around would be to save copies of the built plugin libraries and install them manually.

2) F12 devel includes Audacious 2.1. I haven't tried to built the plugin with that upgrade yet.

Comment 1 Michael Schwendt 2009-09-02 11:28:12 UTC
Created attachment 359510 [details]
spec changes

This would be rather clean spec changes, with %build and %install separated nicely.

Comment 2 Matthias Saou 2009-09-12 21:17:42 UTC
Changes look fine, thanks a lot.

I've rebuilt it for devel, will push an F-11 update (had to re-introduce the distag for it).

Comment 3 Matthias Saou 2009-09-12 21:29:06 UTC
Seems like you were right to warn about the F12 audacious package, as I had also tested only on F11 where evrything went fine, but the build has failed on devel :
http://koji.fedoraproject.org/koji/getfile?taskID=1674229&name=build.log

I'll have a closer look when I have time.

Comment 4 Matthias Saou 2009-09-14 22:17:49 UTC
I've tried looking into this, unfortunately since my main build system is still Fedora 10, I can create F-12 roots with mach because of the XZRpmPayloads.

Comment 5 Michael Schwendt 2009-09-15 10:57:33 UTC
Turns out that Audacious2 on F-12 includes the crossfade plugin already.

And if it didn't, the build-fix would have been as easy as adding  ac_cv_path_AUDACIOUS=/usr/bin/audacious2  to the %configure line.

Comment 6 Michael Schwendt 2009-12-09 16:01:48 UTC
I'm withdrawing this request. We don't have the resources to deal with this, considering that the plugin is included with Audacious on F-12 and older releases of Audacious are not in anything like a "brilliant" state.

Comment 7 Matthias Saou 2009-12-09 17:01:09 UTC
Thanks :-) That was pretty much what I was about to suggest anyway...


Note You need to log in before you can comment on or make changes to this bug.