Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 518187 - Package installs broken symlinks
Summary: Package installs broken symlinks
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lam
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-19 11:53 UTC by Steve Snyder
Modified: 2011-10-04 21:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 21:43:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Steve Snyder 2009-08-19 11:53:26 UTC
Description of problem:

Package installs several broken symlinks

Version-Release number of selected component (if applicable):

lam-7.1.2-14.el5

How reproducible:

Didn't try

Steps to Reproduce:
1. Install RHEL v5.3
2. Note broken LAM symlinks
  
Actual results:

Broken symlinks

Expected results:

All symlinks should resolve.

Additional info:

# symlinks -tr /usr/lib/lam/bin/
dangling: /usr/lib/lam/bin/hf77 -> mpif77
dangling: /usr/lib/lam/bin/hcc -> mpicc
dangling: /usr/lib/lam/bin/hcp -> mpiCC

# rpm -v -V lam | grep bin               
........    /usr/lib/lam/bin                             
........    /usr/lib/lam/bin/bfctl                       
........    /usr/lib/lam/bin/bfstate                     
........    /usr/lib/lam/bin/doom                        
........    /usr/lib/lam/bin/fctl                        
........    /usr/lib/lam/bin/filedr                      
........    /usr/lib/lam/bin/fstate                      
........    /usr/lib/lam/bin/hboot                       
........    /usr/lib/lam/bin/hcc                         
........    /usr/lib/lam/bin/hcp                         
........    /usr/lib/lam/bin/hf77                        
........    /usr/lib/lam/bin/ipcdr                       
........    /usr/lib/lam/bin/kdump                       
........    /usr/lib/lam/bin/lamboot                     
........    /usr/lib/lam/bin/lamcheckpoint               
........    /usr/lib/lam/bin/lamclean                    
........    /usr/lib/lam/bin/lamd                        
........    /usr/lib/lam/bin/lamd_bforward               
........    /usr/lib/lam/bin/lamd_bufferd                
........    /usr/lib/lam/bin/lamd_dli_inet               
........    /usr/lib/lam/bin/lamd_dlo_inet               
........    /usr/lib/lam/bin/lamd_echod                  
........    /usr/lib/lam/bin/lamd_filed
........    /usr/lib/lam/bin/lamd_flatd
........    /usr/lib/lam/bin/lamd_haltd
........    /usr/lib/lam/bin/lamd_iod
........    /usr/lib/lam/bin/lamd_kenyad
........    /usr/lib/lam/bin/lamd_kernel
........    /usr/lib/lam/bin/lamd_loadd
........    /usr/lib/lam/bin/lamd_router
........    /usr/lib/lam/bin/lamd_traced
........    /usr/lib/lam/bin/lamd_versiond
........    /usr/lib/lam/bin/lamexec
........    /usr/lib/lam/bin/lamgrow
........    /usr/lib/lam/bin/lamhalt
........    /usr/lib/lam/bin/laminfo
........    /usr/lib/lam/bin/lamnodes
........    /usr/lib/lam/bin/lamrestart
........    /usr/lib/lam/bin/lamshrink
........    /usr/lib/lam/bin/lamtrace
........    /usr/lib/lam/bin/lamwipe
........    /usr/lib/lam/bin/loadgo
........    /usr/lib/lam/bin/mpiexec
........    /usr/lib/lam/bin/mpimsg
........    /usr/lib/lam/bin/mpirun
........    /usr/lib/lam/bin/mpitask
........    /usr/lib/lam/bin/recon
........    /usr/lib/lam/bin/state
........    /usr/lib/lam/bin/sweep
........    /usr/lib/lam/bin/tkill
........    /usr/lib/lam/bin/tping
........    /usr/lib/lam/bin/wipe

Comment 1 Doug Ledford 2011-10-04 21:43:47 UTC
This bug is exceedingly stale.

As it turns out, the problem is that lam is split up into lam, lam-devel, and lam-libs.  The symlinks should have been part of lam-devel (which contains the mpi programs the symlinks point to), but that was missed.  The easy workaround of course is to just install lam-devel and there are no dangling symlinks.

Given that I doubt lam will ever see another update in rhel5, and given that this has such an easy workaround and no real ill side-effects, I'm closing this bug out as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.