Bug 518194 - askmethod boot option allows installation from HDD only
askmethod boot option allows installation from HDD only
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
NeedsRetesting
:
: 523291 (view as bug list)
Depends On:
Blocks: F12Beta/F12BetaBlocker
  Show dependency treegraph
 
Reported: 2009-08-19 08:42 EDT by Jan Stodola
Modified: 2012-03-20 04:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 11:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Select Partition screen (21.46 KB, image/png)
2009-08-19 08:42 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2009-08-19 08:42:35 EDT
Created attachment 357930 [details]
Select Partition screen

Description of problem:
Use of "askmethod" as a kernel boot option doesn't allow to change installation source during installation. The only source I can use is installation from HDD.

Version-Release number of selected component (if applicable):
rawhide-20090818, anaconda-12.15-1.fc12, tested with x86_64 boot.iso in kvm

How reproducible:
always

Steps to Reproduce:
1. boot from boot.iso, add "askmethod" boot option
2. select language
3. select keyboard type
4. Select Partition screen is shown
  
Actual results:
Select Partition screen (see screenshot)

Expected results:
list of available methods - ie. cdrom, nfs, url, hdd
Comment 1 Chris Lumens 2009-08-19 09:48:17 EDT
This should be fixed in anaconda-12.16.
Comment 2 Scott Robbins 2009-08-23 08:19:24 EDT
Latest boot.iso from downloads.fedora.redhat.com still has the same problem.  

(23 August 2009 Date is shown for the ISO)
Comment 3 Scott Robbins 2009-08-25 13:05:43 EDT
Just tried the alpha, which is apparently anaconda 12.16.  (Judging from the fact that when trying from CD1, it said anaconda 12.16.  Same issue still exists, with both boot and net isos.
Comment 4 James Laska 2009-08-25 13:43:46 EDT
(In reply to comment #3)
> Just tried the alpha, which is apparently anaconda 12.16.  (Judging from the
> fact that when trying from CD1, it said anaconda 12.16.  Same issue still
> exists, with both boot and net isos.  

F-12-Alpha currently ships with anaconda-12.15.  Should you wish to verify this fix, you may download a boot.iso from rawhide (see https://fedoraproject.org/wiki/Releases/Rawhide#Direct_daily_Rawhide_install).

Thanks!
Comment 5 Scott Robbins 2009-08-25 14:30:47 EDT
James, you are 100 percent right.  (I had checked the boot.iso, see our discussion on testing list.)

These aging eyes, however, misread the booting from CD1 and thought that it said 12.16.  Just rebooted after your post here, and yes, you are correct, CD1, as well as boot.iso are 12.15, not 16. 

Apologies for any confusion caused by poor eyesight.
Comment 6 James Laska 2009-08-25 14:46:04 EDT
Thanks for the quick feedback Scott!  I was concerned we had a goof and there was a mismatch between what was tested and what was released as the alpha.  If you do have a moment, testing this against a rawhide boot.iso would be much appreciated!
Comment 7 Scott Robbins 2009-08-25 18:04:04 EDT
I did that earlier actually.  :)  Yes, both boot and net.iso still only give hard drive options, ignoring askmethod.  

Thanks for the quick responese, both here and on the testing list.
Comment 8 Radek Vykydal 2009-08-26 13:45:29 EDT
Patch sent for review:
https://www.redhat.com/archives/anaconda-devel-list/2009-August/msg00335.html
This bug seems like duplicate of bug #516973.
Comment 9 Scott Robbins 2009-09-06 00:52:34 EDT
The Sept. 5th boot.iso seems to have overcome the problem.  I was in a hurry, so didn't test it completely, but doing askmethod did give me the options for NFS, URL, etc.
Comment 10 Scott Robbins 2009-09-06 11:47:26 EDT
Ok, seems I posted too soon.

If one does ask method, after keyboard and language, it goes to what it's been doing, just offering hard disk.  

One can then hit back, where you're able to specify URL or NFS.  However, as soon as it tries to get an address via dhcp, it crashes and says you may now safely reboot your machine. 

This was trying in a Virtual Machine.  I haven't tried on anything else. 

This is the boot.iso from Sept. 5th, 2009.
Comment 11 Radek Vykydal 2009-09-10 06:03:01 EDT
Should be fixed in version 12.24 of anaconda.
Comment 12 John Poelstra 2009-09-11 11:28:00 EDT
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-11. The next action is to test and confirm that this issue is fixed.
Comment 13 Liam Li 2009-09-14 22:31:28 EDT
we are having pre-Beta installation testing against rawhide, but the rawhide is still broken, when it will be ready?
Comment 14 Radek Vykydal 2009-09-15 04:55:56 EDT
anaconda 12.24 should be in rawhide since Sep 12. I don't know when rawhide will be installable. Concerning this bug, it is likely that at least stage 1 (loader) of rawhide is testable.
Comment 15 Radek Vykydal 2009-09-15 11:11:48 EDT
*** Bug 523291 has been marked as a duplicate of this bug. ***
Comment 16 Scott Robbins 2009-09-15 15:07:53 EDT
The Sept. 15th boot.iso at koji

http://kojipkgs.fedoraproject.org/mash/rawhide/i386/os/images/  

(I've only tried, so far, with the i386 image) seems to have fixed this.  It's back to giving me the various options when expected--that is, it doesn't start with just showing disks, making me click back).  It also doesn't crash after getting a network address. 

Thank you.
Comment 17 John Poelstra 2009-09-18 11:26:45 EDT
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-18 and determined that it should be closed based on comment #16.
Comment 18 Joachim Frieben 2009-09-19 13:04:42 EDT
Even older images worked correctly: it was sufficient to omit "askmethod" because stage2.img is included in the image as opposed to earlier small boot.iso images which had a size of about 20 MB only.
Once the graphical installer reaches the repo stage, the user is always prompted to add a network interface in case there no one active - and there you go!

Note You need to log in before you can comment on or make changes to this bug.