Bug 518222 - ISE when searching for packages in non-specified channel
Summary: ISE when searching for packages in non-specified channel
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-08-19 14:47 UTC by Tomas Lestach
Modified: 2014-07-04 13:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:25:42 UTC


Attachments (Terms of Use)

Description Tomas Lestach 2009-08-19 14:47:59 UTC
Description of problem:
Getting ISE, when no channels are available and a package search is started for a non-specified channel.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090730.0
Satellite-5.3.0-RHEL4-re20090811.0

How reproducible:
always

Steps to Reproduce:
1. log in as "RHN Satellite Administrator" into sat
2. create a new organisation
3. log in as new organisation admin
(make sure, there are no channels found for the new organisation)
4. click Channels - Package Search
5. type anything into "Search For" edit box (or nothing),
select 2nd "Where to search" radio button - "Specific channel you have access to" (because the organisation has no channels, you're unable to select any channel from the combo box),
click "Search" button
  
Actual results:
Internal Server Error
The server experienced a problem which prevented your request from being filled out. It may not be possible to execute this action at this time.
Please help us correct this problem by contacting us with details of how you received this message.

Expected results:
No ISE.
Either "No packages found" message or the 2nd radio button shall be disabled, when no channels available


Note You need to log in before you can comment on or make changes to this bug.