Bug 518282 - pulseaudio is having a fit.
pulseaudio is having a fit.
Status: CLOSED DUPLICATE of bug 501769
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-19 14:07 EDT by W Agtail
Modified: 2009-08-19 15:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 15:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio messages (34.77 KB, text/plain)
2009-08-19 14:07 EDT, W Agtail
no flags Details

  None (edit)
Description W Agtail 2009-08-19 14:07:09 EDT
Created attachment 357967 [details]
pulseaudio messages

Description of problem:
When I play music files or CDs, after a short while pulseaudio consumes +80% of CPU and the music plays at a much faster rate (like someone has hit the fast forward button).

Version-Release number of selected component (if applicable):
All latest F11 updates applied as of today.

How reproducible:
Play some music, say Rhythmbox and after a few seconds, the above happens.

Steps to Reproduce:
1. boot system
2. play music files or a music CD via rhythmbox.
3. 
  
Actual results:
Music appears to go in fast forward mode and CPU util goes through the roof.

Expected results:
Able to play music.

Additional info:
See attached from /var/log/messages.
After searching the www, I came across this work-a-round which allows me to listen to music at normal speed :) and is reasonably stable.

diff default.pa.orig default.pa.good 
53c53
< load-module module-hal-detect
---
> load-module module-hal-detect tsched=0


Another 'feature' with rythmbox, is that if I skip to the next song, the volume of sound either decreases or ends up muted.

I hope this info means something to you and you are able to help.
Many thanks.
Comment 1 Lennart Poettering 2009-08-19 15:59:04 EDT
snd_pcm_delay/snd_pcm_avail is overflowing. This is a driver bug.

*** This bug has been marked as a duplicate of bug 501769 ***

Note You need to log in before you can comment on or make changes to this bug.