Bug 518283 - Standardize anaconda logging output
Standardize anaconda logging output
Status: CLOSED DUPLICATE of bug 524980
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-19 14:07 EDT by Chris Lumens
Modified: 2009-09-23 10:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 10:44:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lumens 2009-08-19 14:07:18 EDT
Various consumers of anaconda's logging output would find it handy if we did a better job with what we log.  Among these consumers are various customer monitoring tools, anamon, snake, etc.

Work that would be required to do this:

- Get remote logging working in loader.
- Audit our log messages to see what can be cut.  The storage code in particular is probably logging too much stuff.
- Standardize messages to be more easily machine-parseable, and probably document this "API" somewhere.  Promise not to change it.
- Log both when we enter and leave a dispatcher step.
- Log major points in anaconda:  all filesystems mounted, package selection starting, etc.  This might provide a better way to know where an error happened.
- Log packages being installed, what kickstart scriptlets are being executed, etc.
- Make sure all programs we execute are going into program.log, and perhaps make sure these other log files get sent out via remote logging as well.
- Investigate if there's a better mechanism to use for remote logging than just syslog.  Is there something more easily consumable?
Comment 1 Chris Lumens 2009-09-23 10:44:11 EDT
Good thing I filed this bug twice, huh?

*** This bug has been marked as a duplicate of bug 524980 ***

Note You need to log in before you can comment on or make changes to this bug.