Bug 518292 - Unable to specify specific node with condor_restart
Summary: Unable to specify specific node with condor_restart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid
Version: 1.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: 1.2
: ---
Assignee: Robert Rati
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-19 18:23 UTC by Robert Rati
Modified: 2010-03-16 14:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Grid bug fix C: C: Attempting to specify a specific node when issuing a condor_restart fails. F: R: MORE INFORMATION REQUIRED FOR RELEASE NOTE
Clone Of:
Environment:
Last Closed: 2010-03-16 14:32:03 UTC


Attachments (Terms of Use)

Description Robert Rati 2009-08-19 18:23:02 UTC
Description of problem:
It's not possible to specify a specific node when issuing a condor_restart:
condor_restart -collector mrg29.lab.bos.redhat.com

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Robert Rati 2009-08-27 15:39:49 UTC
Fixed in:
condor-7.3.2-0.5

Comment 2 Martin Kudlej 2009-09-09 13:03:55 UTC
How could I test this issue?

Collector is running:
$ ps aux | grep coll
condor   28491  0.4  0.1  51400  9136 ?        Ssl  11:44   0:04 condor_collector -f

This doesn't work:
$ condor_restart -collector localhost
Found no ClassAds when querying pool (local)
Can't find address for collector localhost.localdomain
Perhaps you need to query another pool.

also these don't work:
$ condor_restart -collector `hostname`
Found no ClassAds when querying pool (local)
Can't find address for collector HOSTNAME
Perhaps you need to query another pool.

$ condor_restart `hostname` -collector
Found no ClassAds when querying pool (local)
Can't find address for collector HOSTNAME
Perhaps you need to query another pool.

$ condor_restart localhost -collector
Found no ClassAds when querying pool (local)
Can't find address for collector localhost.localdomain
Perhaps you need to query another pool

$ condor_restart -name localhost -collector
Found no ClassAds when querying pool (local)
Can't find address for collector localhost.localdomain
Perhaps you need to query another pool.

$ condor_restart -name `hostname` -collector
Found no ClassAds when querying pool (local)
Can't find address for collector HOSTNAME
Perhaps you need to query another pool.

"condor_status -pool `hostname`" works as I expect, it writes list of slots only on HOSTNAME.
There is "condor_status -pool <name> Get information from collector <name>" in documentation, so with which parameter should I run condor_restart? Is it pool name, collector name or hostname?
I've tested it on Rhel 5.3 condor 7.4.0-0.3.el5.

--------------------------------
On Rhel 5.4 condor-7.2.2-0.9.el5 it looks different:

$ condor_restart -collector `hostname`
Unrecognized daemon type while resolving names
Use "-help" to see usage information

$ condor_restart `hostname` -collector
Unrecognized daemon type while resolving names
Use "-help" to see usage information

$ condor_restart -name `hostname` -collector
Unrecognized daemon type while resolving names
Use "-help" to see usage information

Comment 3 Robert Rati 2009-09-09 16:41:10 UTC
You can use any daemon, not just the collector (ie condor_restart -subsystem job_router) not just the collector.  The daemon must be registered with the collector (condor_status -any will show registered collectors).

Comment 5 Irina Boverman 2009-10-29 14:29:54 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
please see bug summary.

Comment 6 Lana Brindley 2009-11-05 04:16:00 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,8 @@
-please see bug summary.+Grid bug fix
+
+C: 
+C: Attempting to specify a specific node when issuing a condor_restart fails.
+F:
+R:
+
+MORE INFORMATION REQUIRED FOR RELEASE NOTE

Comment 7 Martin Kudlej 2009-11-18 14:07:00 UTC
Tested on RHEL 5.4/4.8 x x86_64/i386 with condor-7.4.1-0.5 and it works. -->VERIFIED

Tested by command: condor_restart -subsystem <name>
where <name> is collector, master, schedd, startd or negotiator.

Comment 8 Martin Kudlej 2009-11-18 14:58:21 UTC
I tested it again for sure with command condor_restart -subsystem collector <remote machine> and it doesn't work. -->ASSIGNED

Comment 9 Robert Rati 2009-11-19 13:53:38 UTC
Performing a:

condor_restart -subsystem job_router <remote host>

Would produce an error:

Can't find address for collector <remote host>
Perhaps you need to query another pool.

Because the tools were not properly performing a lookup for the collector in a pool.  Modified the tools to properly lookup collectors in a pool, and now remote subsystems can be restarted/reconfigured as expected.

Comment 10 Lana Brindley 2009-11-19 20:10:42 UTC
On advice from Jeff, this bug has been removed from the relnotes. Flag set to - (denied).

LKB

Comment 11 Martin Kudlej 2009-12-01 13:59:08 UTC
Tested on RHEL 5.4/4.8 x x86_64/i386 with condor-7.4.1-0.7 and it works for master, schedd, startd or negotiator.
-->VERIFIED and create new BZ for collector.

Tested by command: condor_restart -subsystem <name> -name <target hostname>
where <name> is collector, master, schedd, startd or negotiator.

Comment 12 Jeff Needle 2010-03-16 14:32:03 UTC
The fix for this bug was included in the MRG 1.2 release.

Comment 13 Jeff Needle 2010-03-16 14:35:41 UTC
The fix for this bug was included in the MRG 1.2 release.


Note You need to log in before you can comment on or make changes to this bug.