Bug 518391 - mouse not moving but clicks work (Xen guest)
mouse not moving but clicks work (Xen guest)
Status: CLOSED DUPLICATE of bug 523914
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-20 04:53 EDT by Michal Schmidt
Modified: 2009-10-06 23:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-06 23:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log diff between the working and broken xorg-x11-drv-evdev (2.00 KB, text/plain)
2009-08-20 04:53 EDT, Michal Schmidt
no flags Details
full Xorg.0.log with the broken evdev driver (10.44 KB, text/plain)
2009-08-20 04:55 EDT, Michal Schmidt
no flags Details
output of lshal (18.17 KB, text/plain)
2009-08-20 04:56 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Michal Schmidt 2009-08-20 04:53:13 EDT
Created attachment 358054 [details]
Xorg.0.log diff between the working and broken xorg-x11-drv-evdev

Description of problem:
Updated xorg-x11-drv-evdev broke mouse movement in a Xen F11 guest. I access the guest's console using virt-manager. The mouse pointer does not move, although clicking works.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.2.4-1.fc11.x86_64
xorg-x11-server-Xorg-1.6.2-3.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start the F11 guest using virt-manager.
2. When gdm screen appears, try to move the mouse.
  
Actual results:
The mouse pointer stays centered on the guest screen.

Expected results:
The mouse pointer should move.

Additional info:
Downgrading to xorg-x11-drv-evdev-2.2.1-3.fc11 fixes the bug.
Comment 1 Michal Schmidt 2009-08-20 04:55:16 EDT
Created attachment 358055 [details]
full Xorg.0.log with the broken evdev driver

I have no xorg.conf.
Comment 2 Michal Schmidt 2009-08-20 04:56:31 EDT
Created attachment 358056 [details]
output of lshal
Comment 3 Michal Schmidt 2009-08-25 15:02:34 EDT
Rawhide has the same problem.
Comment 4 Matěj Cepl 2009-08-25 17:58:00 EDT
Request for more information has been filed (with reference to https://fedoraproject.org/wiki/Xorg/Input_Triage_Algorithm over Jabber.
Comment 5 Peter Hutterer 2009-08-25 20:01:54 EDT
I need to see how the Xen virtual pointer device looks like.

Please download http://people.freedesktop.org/~whot/evtest.c, compile it
with gcc -o evtest evtest.c and then run it as root against the devile file.
The device file is /dev/input/eventX, where X is a number. You can get the
right device file by looking into /proc/bus/input/devices.

You need to run this command in the guest.
Comment 6 Michal Schmidt 2009-08-26 07:57:14 EDT
Here's the output from evtest:

Input driver version is 1.0.0
Input device ID: bus 0x1 vendor 0x5853 product 0xfffe version 0x0
Input device name: "Xen Virtual Pointer"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
    Event code 275 (SideBtn)
    Event code 276 (ExtraBtn)
    Event code 277 (ForwardBtn)
    Event code 278 (BackBtn)
    Event code 279 (TaskBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
    Event code 8 (Wheel)
  Event type 3 (Absolute)
    Event code 0 (X)
      Value    385
      Min        0
      Max      800
    Event code 1 (Y)
      Value    279
      Min        0
      Max      600
Grab succeeded, ungrabbing.
Testing ... (interrupt to exit)
Event: time 1251287632.679344, type 3 (Absolute), code 0 (X), value 384
Event: time 1251287632.679363, -------------- Report Sync ------------
Event: time 1251287632.686767, type 3 (Absolute), code 0 (X), value 382
Event: time 1251287632.686780, type 3 (Absolute), code 1 (Y), value 280
Event: time 1251287632.686785, -------------- Report Sync ------------
Event: time 1251287632.733736, type 3 (Absolute), code 0 (X), value 383
Event: time 1251287632.733751, type 3 (Absolute), code 1 (Y), value 282
Event: time 1251287632.733756, -------------- Report Sync ------------
Event: time 1251287632.733764, type 3 (Absolute), code 1 (Y), value 283
Event: time 1251287632.733769, -------------- Report Sync ------------
Event: time 1251287632.733774, type 3 (Absolute), code 0 (X), value 385
Event: time 1251287632.733779, type 3 (Absolute), code 1 (Y), value 289
Event: time 1251287632.733784, -------------- Report Sync ------------
Event: time 1251287632.733789, type 3 (Absolute), code 0 (X), value 389
Event: time 1251287632.733794, type 3 (Absolute), code 1 (Y), value 293
Event: time 1251287632.733799, -------------- Report Sync ------------
...
Comment 7 Michal Schmidt 2009-09-14 11:54:47 EDT
Is there some other information I could provide?
Comment 8 Peter Hutterer 2009-10-06 23:49:39 EDT
Bug 523914 describes the same issue, it's present in F11 and rawhide and has the same cause.

*** This bug has been marked as a duplicate of bug 523914 ***

Note You need to log in before you can comment on or make changes to this bug.