Bug 518427 - Bad 'Cancel' behaviour
Bad 'Cancel' behaviour
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On: 517257
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-08-20 07:42 EDT by Tim Waugh
Modified: 2009-10-08 23:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.13-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 13:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-08-20 07:42:11 EDT
Description of problem:
When clicking 'Cancel' on a PolicyKit authorization dialog, the dialog is presenting again.  Clicking 'Cancel' shows this dialog once more, then the IPP authorization dialog is presented, then the PolicyKit dialog three more times before the operation is given up.

Cancel should mean Cancel.

Version-Release number of selected component (if applicable):
system-config-printer-1.1.11-4.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Server->Settings
2.Click Cancel
  
Actual results:
More dialogs.

Expected results:
No more dialogs.
Comment 1 Tim Waugh 2009-08-20 08:04:50 EDT
Caused by bug #517257.
Comment 2 Tim Waugh 2009-08-20 08:07:02 EDT
Fixed upstream.
Comment 3 Fedora Update System 2009-10-08 23:32:33 EDT
system-config-printer-1.1.13-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.