Bug 518481 - Fails to load any page
Summary: Fails to load any page
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: devhelp
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 15:11 UTC by Tim Waugh
Modified: 2009-08-23 18:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-23 18:46:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 572022 None None None Never

Description Tim Waugh 2009-08-20 15:11:31 UTC
Description of problem:
I just get an error message shown instead of documentation.

For example:

Error stating file '/home/twaugh/file/usr/share/gtk-doc/html/pygtk/index.html': No such file or directory

Version-Release number of selected component (if applicable):
devhelp-0.23.1-1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Try to view any documentation.
  
Actual results:
Can't.

Expected results:
Can.

Additional info:
Was working until recently.

Comment 1 Matthew Barnes 2009-08-20 15:42:01 UTC
Stupid question, but I assume the files it's trying to load actually do exist?

Comment 2 Tim Waugh 2009-08-20 16:12:54 UTC
If you remove '/home/twaugh/file' from the beginning of the pathname, yes, those files exist.

It's looking in the wrong place for them though, as you can see (/home/twaugh/file).

Comment 3 Matthew Barnes 2009-08-20 16:21:22 UTC
Wild guess but I bet it's passing a file path to a function that expects a URI, or vice versa.  I'll see if there's anything like this upstream.

Comment 4 Matthew Barnes 2009-08-20 16:38:28 UTC
I found this upstream bug which looks identical:
http://bugzilla.gnome.org/show_bug.cgi?id=572022

The corresponding commit:
http://git.gnome.org/cgit/devhelp/commit/?id=af67fbedccab5044808a489a9f3a5540d42adcf2

But that fix was included in version 0.23.1.  So either there's similar breakage elsewhere in Devhelp or this is a WebKit issue.  Perhaps make sure you have the latest webkitgtk package?

Comment 5 Tim Waugh 2009-08-20 16:48:30 UTC
webkitgtk-1.1.12-1.fc12.x86_64

Comment 6 Edward Sheldrake 2009-08-21 17:21:32 UTC
I ran into this, I solved it by not applying the devhelp-load-uris.patch, the resulting devhelp appears to work fine.

The webkitgtk NEWS file suggests webkitgtk >= 1.1.1 has different functions for loading files and loading URIs.

Comment 7 Matthew Barnes 2009-08-21 18:35:10 UTC
Interesting.  I tried removing that patch and building Devhelp 0.23.1 patch-free with the latest WebKit/GTK, libsoup and GTK+ from Rawhide.  Devhelp can now find the pages, but instead of rendering the pages it's showing me raw HTML code.

I'm running kind of a hybrid F-11/F-12 system though, so I guess I can build a new package with those changes as see if you guys see the same thing as me.

Comment 8 Matthew Barnes 2009-08-21 18:45:43 UTC
Build is done.  Give devhelp-0.23.1-2.fc12 a try.

Comment 9 Edward Sheldrake 2009-08-21 20:05:45 UTC
Unfortunately I also use a similar hybrid setup, "mostly" F-11:
webkitgtk 1.1.12
libsoup 2.27.5 (that webkitgtk requires a 2.27.x)
gtk2 2.16.5

FWIW the webkitgtk NEWS file doesn't match the webkitgtk gtk-doc, devhelp has it's own code for adding the "file://" now, but still uses the deprecated webkit_web_view_open, mine still worked after I replaced them all with webkit_web_view_load_uri.

Comment 10 Tim Waugh 2009-08-23 18:41:02 UTC
All working fine with these:

devhelp-0.23.1-2.fc12.x86_64
webkitgtk-1.1.12-2.fc12.x86_64

Comment 11 Matthew Barnes 2009-08-23 18:46:32 UTC
Okay thanks, closing as fixed then.


Note You need to log in before you can comment on or make changes to this bug.