Bug 518500 - F11 LiveCD installer (/usr/bin/liveinst) fails to locate storage devices
Summary: F11 LiveCD installer (/usr/bin/liveinst) fails to locate storage devices
Keywords:
Status: CLOSED DUPLICATE of bug 501768
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 16:10 UTC by Dan Thurman
Modified: 2013-01-10 05:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 17:07:45 UTC


Attachments (Terms of Use)
Installer crash data (16.28 KB, text/plain)
2009-08-20 16:10 UTC, Dan Thurman
no flags Details

Description Dan Thurman 2009-08-20 16:10:51 UTC
Created attachment 358126 [details]
Installer crash data

Description of problem:

(1) F11 LiveCD installer (/usr/bin/liveinst) fails to locate a
    storage device. This problem also exists on DVD, and network-install
    CD.

    The attached file contains the failure of liveinst.


(2) System->Administration->Logical Storage Management is able to
    locate all storage devices except the Seagate 1TB SATA drive:

    Vendor: ATA
    Model: ST31000528AS_9VP105GT
    Firmware: CC35
    Connection: SCSI

(3) Running fdisk -l shows all of the storage devices,
    including the Seagate drive:

# fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000b5fc7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2             351         669     2562367+  83  Linux
/dev/sda3              14         350     2706952+  82  Linux swap / Solaris
/dev/sda4             670      121601   971386290    5  Extended
/dev/sda5             685       13432   102398310   83  Linux
/dev/sda6           13459       26206   102398278+  83  Linux
/dev/sda7           64490      121601   458752108+  83  Linux
/dev/sda8             670         684      120424+  83  Linux
/dev/sda9           13433       13458      208813+  83  Linux
/dev/sda10          51742       64489   102398278+  83  Linux
/dev/sda11          51729       51741      104391   83  Linux
/dev/sda12          38981       51728   102398278+  83  Linux
/dev/sda13          38968       38980      104391   83  Linux
/dev/sda14          26220       38967   102398278+  83  Linux
/dev/sda15          26207       26219      104391   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x69205244

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        4462    35840983+   7  HPFS/NTFS
/dev/sdb2            4463        8924    35841015    7  HPFS/NTFS
/dev/sdb3            8925       15342    51552585    7  HPFS/NTFS
/dev/sdb4           15343       38913   189334057+   5  Extended
/dev/sdb5           15343       15355      104391   83  Linux
/dev/sdb6           15356       38913   189229603+   7  HPFS/NTFS

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x301e301d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1       38913   312568641    7  HPFS/NTFS

Disk /dev/sdd: 100 MB, 100663296 bytes
64 heads, 32 sectors/track, 96 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x726a014e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd4   *           1          96       98288    6  FAT16

(4) After a time in running LiveCD, the kernel panics and
    flashes the Caps-Lock & Scroll-Lock LEDs.

Version-Release number of selected component (if applicable):

N/A

How reproducible:

Every time.

Steps to Reproduce:
1. Place CD/DVD in drive
2. Boot
3. Run installer
  
Actual results:

Fails to locate "Storage Devices..."

Expected results:

Expect to have installer locating the drives and
to continue running without failure

Additional info:

Comment 1 Chris Lumens 2009-08-20 17:07:45 UTC

*** This bug has been marked as a duplicate of bug 501768 ***


Note You need to log in before you can comment on or make changes to this bug.