Bug 518526 - ipa-server-install fails under Fedora 11
Summary: ipa-server-install fails under Fedora 11
Keywords:
Status: CLOSED DUPLICATE of bug 518418
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall
Version: 1.2.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 18:45 UTC by Jason Gerard DeRose
Modified: 2015-01-04 23:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 19:53:35 UTC


Attachments (Terms of Use)
ipaserver-install.log (59.70 KB, text/plain)
2009-08-20 18:45 UTC, Jason Gerard DeRose
no flags Details

Description Jason Gerard DeRose 2009-08-20 18:45:58 UTC
Created attachment 358147 [details]
ipaserver-install.log

Description of problem:

ipa-server-install fails on step 17/17, here is the text from stdout:

Configuring ntpd
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
done configuring ntpd.
Configuring directory server:
  [1/17]: creating directory server user
  [2/17]: creating directory server instance
  [3/17]: adding default schema
  [4/17]: enabling memberof plugin
  [5/17]: enabling referential integrity plugin
  [6/17]: enabling winsync plugin
  [7/17]: configuring uniqueness plugin
  [8/17]: creating indices
  [9/17]: configuring ssl for ds instance
  [10/17]: configuring certmap.conf
  [11/17]: restarting directory server
  [12/17]: adding default layout
  [13/17]: adding delegation layout
  [14/17]: configuring Posix uid/gid generation as first master
  [15/17]: adding master entry as first master
  [16/17]: initializing group membership
  [17/17]: configuring directory to start on boot
Unexpected error - see ipaserver-install.log for details:
 Command '/sbin/chkconfig --list dirsrv' returned non-zero exit status 1


Version-Release number of selected component (if applicable):


How reproducible:

Every time.


Steps to Reproduce:

1. run ipa-server-install
  
Actual results:

doesn't work.

Expected results:

works.


Additional info:

Comment 1 Jason Gerard DeRose 2009-08-20 19:06:42 UTC
Oh, and running `/sbin/chkconfig --list dirsrv` gives:

service dirsrv supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add dirsrv')

Comment 2 Rob Crittenden 2009-08-20 19:11:42 UTC
Re-assigning to the 389 team. The install pre/post scripts should do:

/sbin/chkconfig --add dirsrv

and

/sbin/chkconfig --del dirsrv

Comment 3 Nathan Kinder 2009-08-20 19:53:35 UTC

*** This bug has been marked as a duplicate of bug 518418 ***


Note You need to log in before you can comment on or make changes to this bug.