Bug 518551 - mkinitrd should recognize tabs as field separators in /etc/crypttab
Summary: mkinitrd should recognize tabs as field separators in /etc/crypttab
Keywords:
Status: CLOSED DUPLICATE of bug 501198
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 21:11 UTC by Matt McCutchen
Modified: 2009-08-21 11:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-21 11:42:02 UTC


Attachments (Terms of Use)

Description Matt McCutchen 2009-08-20 21:11:53 UTC
Description of problem:
mkinitrd recognizes only spaces as field separators in /etc/crypttab.  It should recognize tabs too, since `man crypttab` says "fields on the line are delimited by white space".  See bug 501198 comment 20 for a patch.

My case: I recently upgraded my computer from F10 to F11.  /dev/sda6 contains a LUKS-encrypted LVM physical volume that contains the root filesystem.  I prefer to "cryptsetup luksOpen" with the name "pv" rather than some long, unmemorable UUID.  When I first tried to boot with an F11 initrd, I discovered that I needed to write a /etc/crypttab file to tell mkinitrd where the LUKS volume is.  (I never hit the problem with F10: I think mkinitrd just carried this information over from the currently running system each time.)  My instinct was to separate fields with tabs like in /etc/fstab, and that didn't work.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.87-1.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Set up a system with a LUKS-encrypted LVM physical volume opened at a non-UUID name and the root filesystem inside.
2. Make an /etc/crypttab like this (with a tab):
pv	/dev/sda6
3. mkinitrd
4. Try to boot the new initrd.

Actual results:
Plymouth asks three times for the password and the initrd fails to open the LUKS volume.

Expected results:
Plymouth asks once for the password and the initrd successfully opens the LUKS volume.

Comment 1 Hans de Goede 2009-08-21 11:42:02 UTC

*** This bug has been marked as a duplicate of bug 501198 ***


Note You need to log in before you can comment on or make changes to this bug.