Bug 518586 - Review Request: gdata-sharp - .NET library for the Google Data API
Summary: Review Request: gdata-sharp - .NET library for the Google Data API
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Juan Manuel Rodriguez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 07:17 UTC by Michel Alexandre Salim
Modified: 2009-12-24 20:36 UTC (History)
3 users (show)

Fixed In Version: 1.4.0.2-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-24 20:36:01 UTC
nushio: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Michel Alexandre Salim 2009-08-21 07:17:49 UTC
Spec URL: http://salimma.fedorapeople.org/specs/gnome/gdata-sharp.spec
SRPM URL: http://salimma.fedorapeople.org/specs/gnome/gdata-sharp-1.4.0.2-1.fc12.src.rpm

Description:
The Google Data APIs (GData) provide a simple protocol for reading and
writing data on the web.

(needed to build some GNOME Do plugins)

Comment 1 Juan Manuel Rodriguez 2009-08-21 15:19:51 UTC
I checked the Spec: 
rpmlint is clean. No errors or warnings. 
It is Apache Licensed, which passes the license test. 

Now, I tried building it on Koji, and it failed for both 
F11: http://koji.fedoraproject.org/koji/taskinfo?taskID=1622399
F12: http://koji.fedoraproject.org/koji/taskinfo?taskID=1622369

I think its a bug related to mono-nunit22, because the build.log says: 
error CS0006: cannot find metadata file `nunit.framework.dll'

Comment 2 Juan Manuel Rodriguez 2009-08-21 16:34:12 UTC
Ok, so I checked gdata's makefile, and its faulty. 

Line 131 says:
$(CSC) $(DEFINES) -target:library -out:unittests.dll $(ALLREFS) -r:nunit.framework.dll $(test_sources)

I fixed it locally, by replacing the last part with:
-r:/usr/lib/mono/nunit22/nunit.framework.dll $(test_sources)

However, I haven't made a patch that looks on lib64 in case of 64 bit, my patch is only hardcoded to /usr/lib 

I'll try to find some examples for patching, to fix this asap.

Comment 3 Michel Alexandre Salim 2009-08-21 18:22:08 UTC
*Scratches head* why did it work on my local machine? I'll try and work on it too, but if you get done first, just attach the patch to this bug. Thanks!

Comment 4 Michel Alexandre Salim 2009-08-21 18:48:30 UTC
OK, it builds fine now. spec and SRPM at previous place. Here's the Koji build (for F-12):

http://koji.fedoraproject.org/koji/taskinfo?taskID=1623823

Comment 5 Juan Manuel Rodriguez 2009-09-03 04:01:02 UTC
Builds for Fedora 11 too: http://koji.fedoraproject.org/koji/taskinfo?taskID=1651513

My only comments are that the patches aren't commented or reported upstream: 
https://fedoraproject.org/wiki/Packaging/Guidelines#All_patches_should_have_an_upstream_bug_link_or_comment

Other than that, It's good to go.

Comment 6 Michel Alexandre Salim 2009-09-03 06:24:30 UTC
New Koji F-12 build:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=1651585

Updated spec is at the same location, with comments for the following:
- pkgconfig patch already in trunk
- nunit patch no longer necessary, with the fixed -nunit subpackage of F-12's mono (hurrah!)

To test this on F-11, you'd probably have to rebuild Mono yourself. I'll ping Toshio to check if we can start updating Mono packages in F-11 again.

98 out of 921 unit tests currently fail, so while I've added a %check section, the 'make test' invocation is currently commented out. Will check with upstream.

Comment 7 Michel Alexandre Salim 2009-09-03 06:25:59 UTC
Juan, please assign the review to yourself, and set the fedora-review flag to '?' during review and '+' when you declare the package approved. Otherwise it might delay the package getting imported to CVS.

Thanks!

Comment 8 Michel Alexandre Salim 2009-09-14 00:18:10 UTC
Changing status to ASSIGNED, just in case someone mistakenly lands on this bug looking for something to review.

Juan, could you update the review? It's blocking gnome-do-plugins.

Comment 9 Juan Manuel Rodriguez 2009-09-23 18:04:18 UTC
I managed to build it under Fedora 11, no need for rebuilding mono or anything (Maybe the updated mono packages landed already?)

The patches still need a comment on the upstream bug or the reason why they're needed. https://fedoraproject.org/wiki/Packaging/Guidelines#All_patches_should_have_an_upstream_bug_link_or_comment

It built on Koji: 
F11: http://koji.fedoraproject.org/koji/taskinfo?taskID=1701309
F12: http://koji.fedoraproject.org/koji/taskinfo?taskID=1701324

What's the status on the PPC / PPC64 rebuild?

Sorry for taking so long for the review, I've been really caught up. I think that's the last thing we're missing.

Comment 10 Michel Alexandre Salim 2009-09-23 23:27:31 UTC
Hi Juan,

Oops, I forgot to commit and push my latest spec. Due to using the normal mono-nunit, it is now buildable on PPC / PPC64 as well. The rebuild is done a few weeks ago, AFAIR.

SRPM:
http://salimma.fedorapeople.org/specs/gnome/gdata-sharp-1.4.0.2-3.fc12.src.rpm

Koji F-11:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1702039

Comment 11 Juan Manuel Rodriguez 2009-10-03 22:31:49 UTC
rpmlint: clean
Header files must be in a -devel package. Done
Patches have a link to the upstream change, which means we'll no longer need them soon. 

Builds correctly on 
F11: http://koji.fedoraproject.org/koji/taskinfo?taskID=1726178
F12: http://koji.fedoraproject.org/koji/taskinfo?taskID=1726186

Package is APPROVED.

Comment 12 Michel Alexandre Salim 2009-10-04 02:42:21 UTC
Many thanks!

New Package CVS Request
=======================
Package Name: gdata-sharp
Short Description: .NET library for the Google Data API
Owners: salimma
Branches: F-11 F-12
InitialCC:

Comment 13 Kevin Fenzi 2009-10-06 17:37:35 UTC
cvs done.

Comment 14 Fedora Update System 2009-12-22 13:04:38 UTC
gdata-sharp-1.4.0.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gdata-sharp-1.4.0.2-3.fc12

Comment 15 Fedora Update System 2009-12-22 13:04:44 UTC
gdata-sharp-1.4.0.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gdata-sharp-1.4.0.2-3.fc11

Comment 16 Fedora Update System 2009-12-24 20:35:56 UTC
gdata-sharp-1.4.0.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2009-12-24 20:36:33 UTC
gdata-sharp-1.4.0.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.